summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>1998-11-05 12:26:43 +0000
committerUlrich Drepper <drepper@redhat.com>1998-11-05 12:26:43 +0000
commitc00160817df41d1581b2e91620c4adb5cba19a74 (patch)
treee7e6ddc0f298f9bfeae879caca98d760cd284d01 /configure.in
parenta92599eaa0f2564251b794649cd531c6cb3b0bf3 (diff)
Update.
1998-11-05 Ulrich Drepper <drepper@cygnus.com> * sysdeps/i386/fpu/bits/mathinline.h (__pow2): Fix fldl -> fld. * sysdeps/libm-i387/s_fma.S: Optimize a bit. * sysdeps/libm-i387/s_fmaf.S: Likewise. 1998-11-04 19:47 -0500 Zack Weinberg <zack@rabi.phys.columbia.edu> * configure.in: Search for install-info and substitute it. Determine whether install-info is the buggy Debian version that doesn't understand INFO-DIR-SECTION. * config.make.in: Add INSTALL_INFO and OLD_DEBIAN_INSTALL_INFO to be substituted. * manual/Makefile: If OLD_DEBIAN_INSTALL_INFO, give install-info the --section argument it needs to work properly. (dir-add.texinfo): Delete target. (dir-add.info): Generate this directly. Sort entries. Put a colon at the end of the INFO-DIR-SECTION line. * manual/libc.texinfo: Put a colon at the end of the @dircategory line. 1998-11-05 Paul Eggert <eggert@twinsun.com> * time/mktime.c (__mktime_internal): Adopt the traditional (and problematic) notion of what to do when tm_isdst doesn't match. 1998-11-04 Andreas Schwab <schwab@issan.cs.uni-dortmund.de> * posix/PTESTS: Fix spelling. 1998-11-04 Andreas Jaeger <aj@arthur.rhein-neckar.de> * elf/dlopenold.c: Compile only if DO_VERSIONING is also defined. 1998-11-03 H.J. Lu <hjl@gnu.org> * libio/fileops.c (new_do_write): New function. (_IO_new_do_write): Call new_do_write. (_IO_new_file_xsputn): Likewise. * libio/oldfileops.c (old_do_write): New function. (_IO_old_do_write): Call old_do_write. (_IO_old_file_xsputn): Likewise.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 30 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 40d9f55a16..0ec4424358 100644
--- a/configure.in
+++ b/configure.in
@@ -558,8 +558,37 @@ fi
AC_SUBST(libc_cv_have_ksh)
AC_PROG_AWK
-AC_PATH_PROGS(PERL, perl, no)
+AC_PATH_PROG(PERL, perl, no)
AC_SUBST(PERL)
+AC_PATH_PROG(INSTALL_INFO, install-info, no, dnl
+/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin)
+AC_SUBST(INSTALL_INFO)
+if test "$INSTALL_INFO" != "no"; then
+AC_CACHE_CHECK(for old Debian install-info, libc_cv_old_debian_install_info,
+ [mkdir conftest.d
+ # There is a hard ^_ on the next line. I am open to better ideas.
+ (echo ''
+ echo 'File: dir Node: Top This is the top of the INFO tree'
+ echo '* Menu:') >conftest.d/dir
+ (echo 'INFO-DIR-SECTION i-d-s works'
+ echo 'START-INFO-DIR-ENTRY'
+ echo '* Prog: (prog). Program.'
+ echo 'END-INFO-DIR-ENTRY') >conftest.d/prog.info
+ if $INSTALL_INFO --info-dir=conftest.d conftest.d/prog.info >&AC_FD_CC 2>&1
+ then
+ if grep -s 'i-d-s works' conftest.d/dir >/dev/null
+ then libc_cv_old_debian_install_info=no
+ else libc_cv_old_debian_install_info=yes
+ fi
+ else libc_cv_old_debian_install_info=no testfailed=t
+ fi
+ rm -fr conftest.d])
+if test -n "$testfailed"
+then AC_MSG_WARN([install-info errored out, check config.log])
+fi
+OLD_DEBIAN_INSTALL_INFO=$libc_cv_old_debian_install_info
+fi
+AC_SUBST(OLD_DEBIAN_INSTALL_INFO)
AC_CACHE_CHECK(for signed size_t type, libc_cv_signed_size_t, [dnl
echo '#include <stddef.h>