summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>1998-04-07 18:05:52 +0000
committerUlrich Drepper <drepper@redhat.com>1998-04-07 18:05:52 +0000
commitdbe7a0f5de17e8fa52ec6d2c9356796ef19af7c8 (patch)
treeb47e58aead2a28c483a3b6376779a1db178ec482 /configure.in
parent7f9a8b5f55cc1409cc93277bbe8449a898bac835 (diff)
Update.
1998-04-07 Ulrich Drepper <drepper@cygnus.com> * configure.in: Recognize --with-headers flag and determine commandline options to be used in compilation. * Makeconfig (+includes): Use $(sysincludes). * config.make.in (sysincludes): Define from SYSINCLUDES. * glibcbug.in: Use SYSINCLUDES information. Patches by Zack Weinberg. * sysdeps/sparc/sparc32/elf/start.S: Rewrite for __libc_start_main. * sysdeps/sparc/sparc64/elf/start.S: Likewise.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9d12825264..44cde5c8eb 100644
--- a/configure.in
+++ b/configure.in
@@ -47,6 +47,12 @@ AC_ARG_WITH(cvs, dnl
with_cvs=$withval, with_cvs=yes)
AC_SUBST(with_cvs)
+AC_ARG_WITH(headers, dnl
+[ --with-headers=PATH location of system headers to use
+ [e.g. /usr/src/linux/include]
+ [default=compiler default]],
+ sysheaders=$withval, sysheaders='')
+
AC_ARG_ENABLE(libio, dnl
[ --enable-libio build in GNU libio instead of GNU stdio],
[if test $enableval = yes; then
@@ -470,6 +476,15 @@ AC_CHECK_TOOL(AR, ar)
AC_CHECK_TOOL(RANLIB, ranlib, :)
AC_CHECK_TOOL(MIG, mig)
+# if using special system headers, find out the compiler's sekrit
+# header directory and add that to the list. NOTE: Only does the right
+# thing on a system that doesn't need fixincludes. (Not presently a problem.)
+if test -n "$sysheaders"; then
+ ccheaders=`$CC -print-file-name=include`
+ SYSINCLUDES="-nostdinc -isystem $ccheaders -isystem $sysheaders"
+fi
+AC_SUBST(SYSINCLUDES)
+
# check if ar takes S
AC_CACHE_CHECK(for ar S, libc_cv_ar_S, [dnl
tmpo=$$.o