summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.de>2001-01-06 17:33:47 +0000
committerAndreas Jaeger <aj@suse.de>2001-01-06 17:33:47 +0000
commitaa44a9de3dcc4bbe55f31b03313e49164b50fa84 (patch)
treedf2da162f89c9b42e43a43c42f7b405d94097b43 /configure.in
parent655bfb8bffc4da7d5c8411a4e2f94919b64d4e02 (diff)
* configure.in: Check for old add-ons that shouldn't be used with current glibc anymore.
2001-01-06 Andreas Jaeger <aj@suse.de> * configure.in: Check for old add-ons that shouldn't be used with current glibc anymore.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6ee1f05ab1..d3daf7debd 100644
--- a/configure.in
+++ b/configure.in
@@ -148,6 +148,21 @@ AC_CONFIG_SUBDIRS($add_ons)
add_ons_pfx=
if test x"$add_ons" != x; then
for f in $add_ons; do
+ # Some sanity checks
+ if test "$f" = "crypt"; then
+ AC_MSG_ERROR([
+*** It seems that you're using an old \`crypt' add-on. crypt is now
+*** part of glibc and using the old add-on will not work with this
+*** release. Start again with fresh sources and without the old
+*** \`crypt' add-on.])
+ fi
+ if test "$f" = "localedata"; then
+ AC_MSG_ERROR([
+*** It seems that you're using an old \`localedata' add-on. localedata
+*** is now part of glibc and using the old add-on will not work with
+*** this release. Start again with fresh sources and without the old
+*** \`localedata' add-on.])
+ fi
# Test whether such a subdir really exists.
if test -d $srcdir/$f; then
add_ons_pfx="$add_ons_pfx $f/"