summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2005-11-05 21:49:48 +0000
committerUlrich Drepper <drepper@redhat.com>2005-11-05 21:49:48 +0000
commit4520d7aac8e37e427f5ab34ffa4418a0eb86104f (patch)
tree23c35b7cbb03a69664961fbf0b792482b3fdde4f /configure.in
parentce33ee7caabb2803294ad7aa8108b039cc00c748 (diff)
* configure.in: Remove test for support for subtracting local labels.
* stdio-common/vfprintf.c: Remove test of HAVE_SUBTRACT_LOCAL_LABELS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 0 insertions, 29 deletions
diff --git a/configure.in b/configure.in
index dae24b503b..15f87fa171 100644
--- a/configure.in
+++ b/configure.in
@@ -1855,35 +1855,6 @@ if test "$libc_cv_gcc_builtin_redirection" = yes ; then
AC_DEFINE(HAVE_BUILTIN_REDIRECTION)
fi
-dnl Check whether the compiler supports subtraction of local labels.
-AC_CACHE_CHECK(for local label subtraction, libc_cv_gcc_subtract_local_labels,
-[cat > conftest.c <<EOF
-changequote(,)dnl
-#line $LINENO "configure"
-int foo (int a)
-{
- static const int ar[] = { &&l1 - &&l1, &&l2 - &&l1 };
- void *p = &&l1 + ar[a];
- goto *p;
- l1:
- return 1;
- l2:
- return 2;
-}
-changequote([,])dnl
-EOF
-dnl No \ in command here because it ends up inside ''.
-if AC_TRY_COMMAND([${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS -nostdlib -nostartfiles
- -o conftest conftest.c -lgcc >&AS_MESSAGE_LOG_FD]); then
- libc_cv_gcc_subtract_local_labels=yes
-else
- libc_cv_gcc_subtract_local_labels=no
-fi
-rm -f conftest*])
-if test "$libc_cv_gcc_subtract_local_labels" = yes; then
- AC_DEFINE(HAVE_SUBTRACT_LOCAL_LABELS)
-fi
-
dnl Check whether the compiler supports the __thread keyword.
if test "x$use__thread" != xno; then
AC_CACHE_CHECK([for __thread], libc_cv_gcc___thread,