summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2001-03-18 21:34:58 +0000
committerUlrich Drepper <drepper@redhat.com>2001-03-18 21:34:58 +0000
commit639c324856be406e80c000720151c34ec6904d87 (patch)
tree66c902de399c96cd4adfa578f888e0fdfa3b0441 /configure.in
parent2bd7e9c3878b2a828999bd7c133419351d4007d7 (diff)
Update.
2001-03-18 Ulrich Drepper <drepper@redhat.com> * Makerules (build-shlib): Remove unnecessary slashes introduced in last change. * configure.in: Test for -Bgroup option of linker. * config.make.in: Define have-Bgroup. * conform/data/unistd.h-data: Require gethostname. * posix/unistd.h: Make gethostname prototype available for __USE_XOPEN2K. * crypt/Makefile: When generating DSO link with libc_nonshared.a. * debug/Makefile: Likewise. * dlfcn/Makefile: Likewise. * hesiod/Makefile: Likewise. * iconvdata/extra-module.mk: Likewise. * locale/Makefile: Likewise. * login/Makefile: Likewise. * math/Makefile: Likewise. * nis/Makefile: Likewise. * nss/Makefile: Likewise. * resolv/Makefile: Likewise. * rt/Makefile: Likewise. * posix/unistd.h (gethostname): Change type of second parameter back to size_t as per upcoming XPG6.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8a478573a5..7696009327 100644
--- a/configure.in
+++ b/configure.in
@@ -992,6 +992,20 @@ EOF
fi
rm -f conftest*])
AC_SUBST(libc_cv_z_initfirst)
+
+ AC_CACHE_CHECK(for -Bgroup option,
+ libc_cv_Bgroup, [dnl
+ cat > conftest.c <<EOF
+int _start (void) { return 42; }
+EOF
+ if AC_TRY_COMMAND([${CC-cc} -shared -o conftest.so conftest.c -Wl,-Bgroup -nostdlib 1>&AC_FD_CC])
+ then
+ libc_cv_Bgroup=yes
+ else
+ libc_cv_Bgroup=no
+ fi
+ rm -f conftest*])
+ AC_SUBST(libc_cv_Bgroup)
fi
if test $elf != yes; then