summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2000-12-05 00:41:57 +0000
committerUlrich Drepper <drepper@redhat.com>2000-12-05 00:41:57 +0000
commit62ab42d67da471a5502ecbe556e7f621dae360d3 (patch)
tree2ad0df6dcb656d0906bfd3f419f24cd1d948516a /configure.in
parent767b6275d7bf9096e3f52348401632e1e58d4896 (diff)
Update.
2000-12-04 H.J. Lu <hjl@gnu.org> * configure.in: Change --with-oldest-abi=ABI to --enable-oldest-abi=ABI. 2000-12-02 Bruno Haible <haible@clisp.cons.org> * stdio-common/perror.c (perror): If stderr is wide-oriented, use fwprintf instead of fprintf. 2000-12-01 H.J. Lu <hjl@gnu.org> * nss/getXXbyYY_r.c: Fix verioned symbol handling. * nss/getXXent_r.c: Likewise. * sysdeps/unix/sysv/linux/i386/chown.c: Likewise. 2000-11-30 H.J. Lu <hjl@gnu.org> * scripts/abi-versions.awk (oldest_abi): New variable. Handle the oldest ABI supported. * Makerules ($(common-objpfx)abi-versions.h): Set oldest_abi for scripts/abi-versions.awk. * configure.in: Add --with-oldest-abi=ABI. * configure: Rebuild. * config.make.in (oldest-abi): New. * config.h.in (GLIBC_OLDEST_ABI): New. * csu/version.c (banner): Support GLIBC_OLDEST_ABI.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 11 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index ed15555834..76d88faf5b 100644
--- a/configure.in
+++ b/configure.in
@@ -82,17 +82,6 @@ AC_ARG_WITH(headers, dnl
[default=compiler default]],
sysheaders=$withval, sysheaders='')
-AC_ARG_WITH(oldest-abi, dnl
-[ --with-oldest-abi=ABI the oldest ABI supported [e.g. 2.2]
- [default=glibc default]],
- oldest_abi=$withval, oldest_abi='')
-if test ! -z "$oldest_abi"; then
- AC_DEFINE_UNQUOTED(GLIBC_OLDEST_ABI, "$oldest_abi")
-else
- oldest_abi=default
-fi
-AC_SUBST(oldest_abi)
-
AC_ARG_ENABLE(libio, dnl
[ --enable-libio build in GNU libio instead of GNU stdio],
[if test $enableval = yes; then
@@ -132,6 +121,17 @@ AC_ARG_ENABLE(versioning, dnl
library objects [default=yes if supported]],
enable_versioning=$enableval, enable_versioning=yes)
+AC_ARG_ENABLE(oldest-abi, dnl
+[ --enable-oldest-abi=ABI configure the oldest ABI supported [e.g. 2.2]
+ [default=glibc default]],
+ oldest_abi=$enableval, oldest_abi=no)
+if test "$oldest_abi" = yes || test "$oldest_abi" = no; then
+ oldest_abi=default
+else
+ AC_DEFINE_UNQUOTED(GLIBC_OLDEST_ABI, "$oldest_abi")
+fi
+AC_SUBST(oldest_abi)
+
dnl Generic infrastructure for drop-in additions to libc.
AC_ARG_ENABLE(add-ons, dnl
[ --enable-add-ons[=DIR1,DIR2]...