summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@hack.frob.com>2011-06-11 00:45:12 -0700
committerRoland McGrath <roland@hack.frob.com>2011-07-14 20:50:17 -0700
commit5c55070081c27168d27145afdf6a92cd56c9abb3 (patch)
tree07be43c6115f3d97746612a57c8fda82031d45a5 /configure.in
parenta6928d5102a89f152fe9d17abb26346dc8cefc9c (diff)
Use linker --print-output-format option if available.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 55e56498c1..a28cd7069e 100644
--- a/configure.in
+++ b/configure.in
@@ -1803,6 +1803,17 @@ EOF
AC_SUBST(libc_cv_hashstyle)
fi
+AC_CACHE_CHECK(linker output format, libc_cv_output_format, [dnl
+if libc_cv_output_format=`
+${CC-cc} -nostartfiles -nostdlib -Wl,--print-output-format 2>&AS_MESSAGE_LOG_FD`
+then
+ :
+else
+ libc_cv_output_format=
+fi
+test -n "$libc_cv_output_format" || libc_cv_output_format=unknown])
+AC_SUBST(libc_cv_output_format)
+
AC_CACHE_CHECK(for -fno-toplevel-reorder -fno-section-anchors, libc_cv_fno_toplevel_reorder, [dnl
cat > conftest.c <<EOF
int foo;