summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1994-05-21 00:42:31 +0000
committerRoland McGrath <roland@gnu.org>1994-05-21 00:42:31 +0000
commitc9e4cf504973423e967ac539123271ed39a0a2c0 (patch)
tree9f9bf74c5e080622893bd1f331fdd85ed4e8391a /configure.in
parent33eddf8759bacb5bfd3ba5a924b78ccf68253263 (diff)
Formerly ../configure.in.~51~
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 728ab57454..9bc21ac3c3 100644
--- a/configure.in
+++ b/configure.in
@@ -319,9 +319,14 @@ while [ $# -gt 0 ]; do
# Find the parent of NAME, using the empty string if it has none.
parent="`echo $name | sed -n -e '/\//!q' -e 's=/[^/]*$==p'`"
- # Append the names implied by NAME, and NAME's parent (if it has one),
- # to the list of names to be processed (the argument list).
- sysnames="`echo $* $implied $parent`"
+ # Add the names implied by NAME, and NAME's parent (if it has one), to
+ # the list of names to be processed (the argument list). We prepend the
+ # implied names to the list and append the parent. We want implied
+ # directories to come before further directories inferred from the
+ # configuration components; this ensures that for sysv4, unix/common
+ # (implied by unix/sysv/sysv4) comes before unix/sysv (in ostry (here $*)
+ # after sysv4).
+ sysnames="`echo $implied $* $parent`"
if [ "$sysnames" != "" ]; then
set $sysnames
fi