summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.de>2001-12-12 18:36:44 +0000
committerAndreas Jaeger <aj@suse.de>2001-12-12 18:36:44 +0000
commit35cd3c9701666164c5bf05eff9afce912cb84fe0 (patch)
treee2e52c6957a47395e66659dea8b94378c2c8fafb /configure.in
parent2bfe5fd1138ee5884605af7f346f74f0fb442211 (diff)
* configure.in: Use -nostartfiles -nostdlib for linker tests, fix
combreloc test so that it works in this case. 2001-12-12 Andreas Jaeger <aj@suse.de> * configure.in: Use -nostartfiles -nostdlib for linker tests, fix combreloc test so that it works in this case. * sysdeps/arm/dl-machine.h (elf_machine_rela): Fix typo in last patch.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 14 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index aefbb4e30f..336104b3a2 100644
--- a/configure.in
+++ b/configure.in
@@ -999,7 +999,9 @@ EOF
cat > conftest.c <<EOF
int _start (void) { return 42; }
EOF
- if AC_TRY_COMMAND([${CC-cc} -shared -o conftest.so conftest.c -Wl,--enable-new-dtags,-z,nodelete 1>&AC_FD_CC])
+ if AC_TRY_COMMAND([${CC-cc} -shared -o conftest.so conftest.c
+ -nostartfiles -nostdlib
+ -Wl,--enable-new-dtags,-z,nodelete 1>&AC_FD_CC])
then
libc_cv_z_nodelete=yes
else
@@ -1013,7 +1015,9 @@ EOF
cat > conftest.c <<EOF
int _start (void) { return 42; }
EOF
- if AC_TRY_COMMAND([${CC-cc} -shared -o conftest.so conftest.c -Wl,--enable-new-dtags,-z,nodlopen 1>&AC_FD_CC])
+ if AC_TRY_COMMAND([${CC-cc} -shared -o conftest.so conftest.c
+ -nostartfiles -nostdlib
+ -Wl,--enable-new-dtags,-z,nodlopen 1>&AC_FD_CC])
then
libc_cv_z_nodlopen=yes
else
@@ -1027,7 +1031,9 @@ EOF
cat > conftest.c <<EOF
int _start (void) { return 42; }
EOF
- if AC_TRY_COMMAND([${CC-cc} -shared -o conftest.so conftest.c -Wl,--enable-new-dtags,-z,initfirst 1>&AC_FD_CC])
+ if AC_TRY_COMMAND([${CC-cc} -shared -o conftest.so conftest.c
+ -nostartfiles -nostdlib
+ -Wl,--enable-new-dtags,-z,initfirst 1>&AC_FD_CC])
then
libc_cv_z_initfirst=yes
else
@@ -1053,9 +1059,12 @@ EOF
AC_CACHE_CHECK(for -z combreloc,
libc_cv_z_combreloc, [dnl
cat > conftest.c <<EOF
-int foo (void) { return 0; }
+extern int bar (void);
+int foo (void) { return bar (); }
EOF
- if AC_TRY_COMMAND([${CC-cc} -shared -o conftest.so conftest.c -Wl,-z,combreloc 1>&AC_FD_CC])
+ if AC_TRY_COMMAND([${CC-cc} -shared -o conftest.so conftest.c
+ -nostdlib -nostartfiles
+ -Wl,-z,combreloc 1>&AC_FD_CC])
then
dnl The following test is a bit weak. We must use a tool which can test
dnl cross-platform since the gcc used can be a cross compiler. Without