summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndreas Schwab <schwab@linux-m68k.org>2011-01-16 21:29:41 -0500
committerUlrich Drepper <drepper@gmail.com>2011-01-16 21:29:41 -0500
commit77e8bddff3fe1395d73515edfbfaa4441f8aa1cb (patch)
tree887b81395deffd240d68f519d135de4c7d2e9300 /configure.in
parentbc425b339b067bebe3d49907e63b0e81eb261bd2 (diff)
Don't override --enable-multi-arch.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in144
1 files changed, 72 insertions, 72 deletions
diff --git a/configure.in b/configure.in
index ad25b9b75a..668dbd1a1e 100644
--- a/configure.in
+++ b/configure.in
@@ -29,8 +29,8 @@ config_vars=
# Check for a --with-gd argument and set libgd-LDFLAGS in config.make.
AC_ARG_WITH([gd],
- AC_HELP_STRING([--with-gd=DIR],
- [find libgd include dir and library with prefix DIR]),
+ AC_HELP_STRING([--with-gd=DIR],
+ [find libgd include dir and library with prefix DIR]),
[dnl
case "$with_gd" in
yes|''|no) ;;
@@ -39,18 +39,18 @@ yes|''|no) ;;
esac
])
AC_ARG_WITH([gd-include],
- AC_HELP_STRING([--with-gd-include=DIR],
- [find libgd include files in DIR]),
- [dnl
+ AC_HELP_STRING([--with-gd-include=DIR],
+ [find libgd include files in DIR]),
+ [dnl
case "$with_gd_include" in
''|no) ;;
*) libgd_include="-I$withval" ;;
esac
])
AC_ARG_WITH([gd-lib],
- AC_HELP_STRING([--with-gd-lib=DIR],
- [find libgd library files in DIR]),
- [dnl
+ AC_HELP_STRING([--with-gd-lib=DIR],
+ [find libgd library files in DIR]),
+ [dnl
case "$with_gd_lib" in
''|no) ;;
*) libgd_ldflags="-L$withval" ;;
@@ -68,34 +68,34 @@ fi
dnl Arguments to specify presence of other packages/features.
AC_ARG_WITH([fp],
- AC_HELP_STRING([--with-fp],
- [if using floating-point hardware @<:@default=yes@:>@]),
+ AC_HELP_STRING([--with-fp],
+ [if using floating-point hardware @<:@default=yes@:>@]),
[with_fp=$withval],
[with_fp=yes])
AC_SUBST(with_fp)
AC_ARG_WITH([binutils],
- AC_HELP_STRING([--with-binutils=PATH],
- [specify location of binutils (as and ld)]),
+ AC_HELP_STRING([--with-binutils=PATH],
+ [specify location of binutils (as and ld)]),
[path_binutils=$withval],
[path_binutils=''])
AC_ARG_WITH([elf],
- AC_HELP_STRING([--with-elf],
- [if using the ELF object format]),
+ AC_HELP_STRING([--with-elf],
+ [if using the ELF object format]),
[elf=$withval],
[elf=no])
AC_ARG_WITH([selinux],
- AC_HELP_STRING([--with-selinux],
- [if building with SELinux support]),
+ AC_HELP_STRING([--with-selinux],
+ [if building with SELinux support]),
[with_selinux=$withval],
[with_selinux=auto])
AC_ARG_WITH([xcoff],
- AC_HELP_STRING([--with-xcoff],
- [if using the XCOFF object format]),
+ AC_HELP_STRING([--with-xcoff],
+ [if using the XCOFF object format]),
[xcoff=$withval],
[xcoff=no])
AC_ARG_WITH([cvs],
- AC_HELP_STRING([--without-cvs],
- [if CVS should not be used]),
+ AC_HELP_STRING([--without-cvs],
+ [if CVS should not be used]),
[with_cvs=$withval],
[with_cvs=yes])
if test "$with_cvs" = yes; then
@@ -107,16 +107,16 @@ fi
AC_SUBST(with_cvs)
AC_ARG_WITH([headers],
- AC_HELP_STRING([--with-headers=PATH],
- [location of system headers to use
+ AC_HELP_STRING([--with-headers=PATH],
+ [location of system headers to use
(for example /usr/src/linux/include)
@<:@default=compiler default@:>@]),
[sysheaders=$withval],
[sysheaders=''])
AC_ARG_ENABLE([sanity-checks],
- AC_HELP_STRING([--disable-sanity-checks],
- [really do not use threads (should not be used except in special situations) @<:@default=yes@:>@]),
+ AC_HELP_STRING([--disable-sanity-checks],
+ [really do not use threads (should not be used except in special situations) @<:@default=yes@:>@]),
[enable_sanity=$enableval],
[enable_sanity=yes])
@@ -139,34 +139,34 @@ dnl [static=$enableval],
dnl [static=yes])
static=yes
AC_ARG_ENABLE([shared],
- AC_HELP_STRING([--enable-shared],
- [build shared library @<:@default=yes if GNU ld & ELF@:>@]),
+ AC_HELP_STRING([--enable-shared],
+ [build shared library @<:@default=yes if GNU ld & ELF@:>@]),
[shared=$enableval],
[shared=default])
AC_ARG_ENABLE([profile],
- AC_HELP_STRING([--enable-profile],
- [build profiled library @<:@default=no@:>@]),
+ AC_HELP_STRING([--enable-profile],
+ [build profiled library @<:@default=no@:>@]),
[profile=$enableval],
[profile=no])
AC_ARG_ENABLE([omitfp],
- AC_HELP_STRING([--enable-omitfp],
- [build undebuggable optimized library @<:@default=no@:>@]),
+ AC_HELP_STRING([--enable-omitfp],
+ [build undebuggable optimized library @<:@default=no@:>@]),
[omitfp=$enableval],
[omitfp=no])
AC_ARG_ENABLE([bounded],
- AC_HELP_STRING([--enable-bounded],
- [build with runtime bounds checking @<:@default=no@:>@]),
+ AC_HELP_STRING([--enable-bounded],
+ [build with runtime bounds checking @<:@default=no@:>@]),
[bounded=$enableval],
[bounded=no])
AC_ARG_ENABLE([versioning],
- AC_HELP_STRING([--disable-versioning],
- [do not include versioning information in the library objects @<:@default=yes if supported@:>@]),
+ AC_HELP_STRING([--disable-versioning],
+ [do not include versioning information in the library objects @<:@default=yes if supported@:>@]),
[enable_versioning=$enableval],
[enable_versioning=yes])
AC_ARG_ENABLE([oldest-abi],
- AC_HELP_STRING([--enable-oldest-abi=ABI],
- [configure the oldest ABI supported @<:@e.g. 2.2@:>@ @<:@default=glibc default@:>@]),
+ AC_HELP_STRING([--enable-oldest-abi=ABI],
+ [configure the oldest ABI supported @<:@e.g. 2.2@:>@ @<:@default=glibc default@:>@]),
[oldest_abi=$enableval],
[oldest_abi=no])
if test "$oldest_abi" = yes || test "$oldest_abi" = no; then
@@ -187,27 +187,27 @@ fi
dnl Generic infrastructure for drop-in additions to libc.
AC_ARG_ENABLE([add-ons],
- AC_HELP_STRING([--enable-add-ons@<:@=DIRS...@:>@],
- [configure and build add-ons in DIR1,DIR2,...
- search for add-ons if no parameter given]),
+ AC_HELP_STRING([--enable-add-ons@<:@=DIRS...@:>@],
+ [configure and build add-ons in DIR1,DIR2,...
+ search for add-ons if no parameter given]),
, [enable_add_ons=yes])
dnl Let the user avoid using TLS. Don't know why but...
AC_ARG_WITH([tls],
- AC_HELP_STRING([--with-tls],
- [enable support for TLS]),
+ AC_HELP_STRING([--with-tls],
+ [enable support for TLS]),
[usetls=$withval],
[usetls=yes])
AC_ARG_WITH([__thread],
- AC_HELP_STRING([--without-__thread],
- [do not use TLS features even when supporting them]),
+ AC_HELP_STRING([--without-__thread],
+ [do not use TLS features even when supporting them]),
[use__thread=$withval],
[use__thread=yes])
AC_ARG_ENABLE([hidden-plt],
- AC_HELP_STRING([--disable-hidden-plt],
- [do not hide internal function calls to avoid PLT]),
+ AC_HELP_STRING([--disable-hidden-plt],
+ [do not hide internal function calls to avoid PLT]),
[hidden=$enableval],
[hidden=yes])
if test "x$hidden" = xno; then
@@ -224,8 +224,8 @@ AC_SUBST(bindnow)
dnl On some platforms we cannot use dynamic loading. We must provide
dnl static NSS modules.
AC_ARG_ENABLE([static-nss],
- AC_HELP_STRING([--enable-static-nss],
- [build static NSS modules @<:@default=no@:>@]),
+ AC_HELP_STRING([--enable-static-nss],
+ [build static NSS modules @<:@default=no@:>@]),
[static_nss=$enableval],
[static_nss=no])
dnl Enable static NSS also if we build no shared objects.
@@ -235,8 +235,8 @@ if test x"$static_nss" = xyes || test x"$shared" = xno; then
fi
AC_ARG_ENABLE([force-install],
- AC_HELP_STRING([--disable-force-install],
- [don't force installation of files from this package, even if they are older than the installed files]),
+ AC_HELP_STRING([--disable-force-install],
+ [don't force installation of files from this package, even if they are older than the installed files]),
[force_install=$enableval],
[force_install=yes])
AC_SUBST(force_install)
@@ -244,8 +244,8 @@ AC_SUBST(force_install)
dnl On some platforms we allow dropping compatibility with all kernel
dnl versions.
AC_ARG_ENABLE([kernel],
- AC_HELP_STRING([--enable-kernel=VERSION],
- [compile for compatibility with kernel not older than VERSION]),
+ AC_HELP_STRING([--enable-kernel=VERSION],
+ [compile for compatibility with kernel not older than VERSION]),
[minimum_kernel=$enableval],
[])
dnl Prevent unreasonable values.
@@ -263,7 +263,7 @@ dnl This is not the default since many of the extra warnings are not
dnl appropriate.
AC_ARG_ENABLE([all-warnings],
AC_HELP_STRING([--enable-all-warnings],
- [enable all useful warnings gcc can issue]),
+ [enable all useful warnings gcc can issue]),
[all_warnings=$enableval],
[])
AC_SUBST(all_warnings)
@@ -444,7 +444,7 @@ if test x"$add_ons" != x; then
;;
*)
test -d "$srcdir/$libc_add_on" || {
- if test -d "$libc_add_on"; then
+ if test -d "$libc_add_on"; then
libc_add_on="`pwd`/$libc_add_on"
else
AC_MSG_ERROR(add-on directory \"$libc_add_on\" does not exist)
@@ -463,7 +463,7 @@ if test x"$add_ons" != x; then
libc_add_on_subdirs=
. "$libc_add_on_frag"
test -z "$libc_add_on" || {
- configured_add_ons="$configured_add_ons $libc_add_on"
+ configured_add_ons="$configured_add_ons $libc_add_on"
if test "x$libc_add_on_canonical" = xunknown; then
AC_MSG_ERROR(fragment must set \$libc_add_on_canonical)
fi
@@ -602,7 +602,7 @@ fi
# For the multi-arch option we need support in the assembler.
AC_CACHE_CHECK([for assembler gnu_indirect_function symbol type support],
- libc_cv_asm_gnu_indirect_function, [dnl
+ libc_cv_asm_gnu_indirect_function, [dnl
cat > conftest.s <<EOF
.type foo,%gnu_indirect_function
EOF
@@ -771,8 +771,8 @@ for b in $base ''; do
for d in $add_ons_pfx ''; do
for a in $add_ons_sfx ''; do
if test -n "$m0$m0sub$b$v$o$m$msub"; then
- try_srcdir="${srcdir}/"
- case "$d" in
+ try_srcdir="${srcdir}/"
+ case "$d" in
/*) try_srcdir= ;;
esac
try="${d}sysdeps$m0$m0sub$b$v$o$m$msub$a"
@@ -807,7 +807,7 @@ case $sysnames_add_ons$sysnames in
*"$multi_arch_d"*)
;;
*)
- multi_arch=no
+ test x"$multi_arch" = xdefault && multi_arch=no
;;
esac
if test x"$multi_arch" != xno; then
@@ -901,7 +901,7 @@ while test $# -gt 0; do
fi
done
if test $found = no; then
- AC_MSG_WARN($name/Implies specifies nonexistent $x)
+ AC_MSG_WARN($name/Implies specifies nonexistent $x)
fi
done
else
@@ -977,7 +977,7 @@ for add_on in $add_ons; do
done
;;
*)
- test -d "$f" || { test -e "$f" && exit 88; }
+ test -d "$f" || { test -e "$f" && exit 88; }
;;
esac
done)
@@ -1214,8 +1214,8 @@ AC_TRY_COMPILE(dnl
#error stddef.h ignored __need_*
#endif
if (&size == NULL || &wchar == NULL) abort ();],
- libc_cv_friendly_stddef=yes,
- libc_cv_friendly_stddef=no)])
+ libc_cv_friendly_stddef=yes,
+ libc_cv_friendly_stddef=no)])
if test $libc_cv_friendly_stddef = yes; then
config_vars="$config_vars
override stddef.h = # The installed <stddef.h> seems to be libc-friendly."
@@ -1305,7 +1305,7 @@ VERS_1 {
};
VERS_2 {
- global: sym;
+ global: sym;
} VERS_1;
EOF
if ${CC-cc} -c $ASFLAGS conftest.s 1>&AS_MESSAGE_LOG_FD 2>&AS_MESSAGE_LOG_FD; then
@@ -1581,7 +1581,7 @@ changequote([,])dnl
fi
fi])
if test "$libc_cv_z_relro" = no; then
- AC_MSG_ERROR(linker with -z relro support required)
+ AC_MSG_ERROR(linker with -z relro support required)
fi
;;
*) ;;
@@ -1863,12 +1863,12 @@ else
if test $ac_cv_prog_cc_works = yes; then
AC_CACHE_CHECK(for _ prefix on C symbol names, libc_cv_asm_underscores,
[AC_TRY_LINK([asm ("_glibc_foobar:");], [glibc_foobar ();],
- libc_cv_asm_underscores=yes,
- libc_cv_asm_underscores=no)])
+ libc_cv_asm_underscores=yes,
+ libc_cv_asm_underscores=no)])
else
AC_CACHE_CHECK(for _ prefix on C symbol names, libc_cv_asm_underscores,
[AC_CHECK_ASM_UNDERSCORE(libc_cv_asm_underscores=yes,
- libc_cv_asm_underscores=no)])
+ libc_cv_asm_underscores=no)])
fi
fi
if test $libc_cv_asm_underscores = no; then
@@ -1929,13 +1929,13 @@ case $machine in
*) cfi_offset=0;;
esac
cat > conftest.s <<EOF
- .text
- .type func,%function
+ .text
+ .type func,%function
func:
- .cfi_startproc
+ .cfi_startproc
.cfi_remember_state
.cfi_rel_offset 1, $cfi_offset
- .cfi_endproc
+ .cfi_endproc
EOF
if AC_TRY_COMMAND(${CC-cc} $ASFLAGS -c conftest.s 1>&AS_MESSAGE_LOG_FD); then
libc_cv_asm_cfi_directives=yes
@@ -2163,7 +2163,7 @@ if test "x$have_selinux" = xyes; then
# See if we have the libaudit library
AC_CHECK_LIB(audit, audit_log_user_avc_message,
- have_libaudit=yes, have_libaudit=no)
+ have_libaudit=yes, have_libaudit=no)
if test "x$have_libaudit" = xyes; then
AC_DEFINE(HAVE_LIBAUDIT, 1, [SELinux libaudit support])
fi