summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.de>2012-03-23 17:37:33 +0100
committerAndreas Jaeger <jaegerandi@gmail.com>2012-03-28 09:31:50 +0200
commit83ef87ba7d5780ecf9d8a2008c9b9b669fe46156 (patch)
treeb856fd35e78b7b2c8cd2765eb580375fc98d73af /configure.in
parent492e01c879b139f2a19c76e1abc171eda5ae5c66 (diff)
Remove sysdeps/elf support from configure.
* configure.in: Remove support for elf directories in sysdeps.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 1 insertions, 18 deletions
diff --git a/configure.in b/configure.in
index 2363015edb..d8c55b102e 100644
--- a/configure.in
+++ b/configure.in
@@ -743,23 +743,6 @@ AC_SUBST(submachine)
# We have now validated the configuration.
-
-# Look for an `elf' subdirectory of each machine directory.
-# We prepend these rather than inserting them whereever the machine appears
-# because things specified by the machine's ELF ABI should override
-# OS-specific things, and should always be the same for any OS on the
-# machine (otherwise what's the point of an ABI?).
-elf_dirs=
-for d in $add_ons_pfx ''; do
- for m in $mach; do
- if test -d $srcdir/${d}sysdeps$m/elf; then
- elf_dirs="$elf_dirs ${d}sysdeps$m/elf"
- fi
- done
-done
-sysnames="`echo $elf_dirs | sed -e 's,//,/,g'` $sysnames"
-
-
# Expand the list of system names into a full list of directories
# from each element's parent name and Implies file (if present).
set $sysnames
@@ -841,7 +824,7 @@ changequote([,])dnl
done
# Add the default directories.
-default_sysnames="sysdeps/generic/elf sysdeps/generic"
+default_sysnames="sysdeps/generic"
sysnames="$names $default_sysnames"
AC_SUBST(sysnames)
# The other names were emitted during the scan.