summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.de>2001-01-23 08:03:26 +0000
committerAndreas Jaeger <aj@suse.de>2001-01-23 08:03:26 +0000
commitea9f119b615918916f54d04bd9f784acdec87dd5 (patch)
tree9a3570e551d2acf1b3f774b4fa9a51383245d67d /configure.in
parent82eafaf7692abc37ce960415dddc78205b2a713a (diff)
Add test for new enough binutils version, move compiler/binutils test up.
* configure.in: Add test for new enough binutils version, move compiler/binutils test up.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 15 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index d3daf7debd..261a5e1b11 100644
--- a/configure.in
+++ b/configure.in
@@ -567,6 +567,21 @@ AC_CHECK_PROG_VER(SED, gsed sed, --version,
[GNU sed version \([0-9]*\.[0-9.]*\)],
[3.0[2-9]*|3.[1-9]*|[4-9]*], SED=: aux_missing=t)
+AC_PROG_CC_LOCAL
+AC_CANONICAL_BUILD
+if test $host != $build; then
+ AC_CHECK_PROGS(BUILD_CC, gcc cc)
+fi
+AC_SUBST(cross_compiling)
+AC_PROG_CPP
+LIBC_PROG_BINUTILS
+AC_CHECK_TOOL(MIG, mig)
+
+# Accept binutils 2.10.1 or newer (and also any ia64 2.9 version)
+AC_CHECK_PROG_VER(AS, $AS, --version,
+ [GNU assembler.* \([0-9]*\.[0-9.]*\(-ia64-[0-9]*\)*\)],
+ [2.10.[1-9]* | 2.1[1-9]* | 2.9-ia64-*], AS=: critic_missing=t)
+
if test -n "$critic_missing"; then
AC_MSG_ERROR([
*** Some critical program is missing or too old.
@@ -582,16 +597,6 @@ test -n "$aux_missing" && AC_MSG_WARN([
CCVERSION=`$CC -v 2>&1 | sed -n 's/gcc version //p'`
AC_SUBST(CCVERSION)
-AC_PROG_CC_LOCAL
-AC_CANONICAL_BUILD
-if test $host != $build; then
- AC_CHECK_PROGS(BUILD_CC, gcc cc)
-fi
-AC_SUBST(cross_compiling)
-AC_PROG_CPP
-LIBC_PROG_BINUTILS
-AC_CHECK_TOOL(MIG, mig)
-
# if using special system headers, find out the compiler's sekrit
# header directory and add that to the list. NOTE: Only does the right
# thing on a system that doesn't need fixincludes. (Not presently a problem.)