summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJakub Jelinek <jakub@redhat.com>2007-01-12 14:37:24 +0000
committerJakub Jelinek <jakub@redhat.com>2007-01-12 14:37:24 +0000
commit00e3dec8025c93ccde8ed810657e7f2115ddc8cb (patch)
tree30b8f6bdb08d364b986ae3ec3ec7664c520f0ad9 /configure.in
parentd6220e9ee38c1c9285221b023346201ec5f511b3 (diff)
* nis/nis_table.c (nis_list): If __follow_path fails in the new
code, make sure the nis_freeresult call doesn't crash and that the result is reported correctly. * nis/nis_table.c (nis_list): Handle FOLLOW_PATH | ALL_RESULTS when callback is NULL. * nis/Versions (libnss_nisplus): Add _nss_nisplus_initgroups_dyn@@GLIBC_PRIVATE. * nis/Makefile (libnss_nisplus-routines): Add nisplus-initgroups. * nis/nss_nisplus/nisplus-grp.c (tablename_val, tablename_len, _nss_create_tablename): Rename to... (grp_tablename_val, grp_tablename_len, _nss_grp_create_tablename): ... these. No longer static. (internal_setgrent): Adjust users. (_nss_nisplus_getgrnam_r, _nss_nisplus_getgrgid_r): Likewise. Don't use locking around _nss_grp_create_tablename call. * nis/nss_nisplus/nisplus-initgroups.c: New file.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in44
1 files changed, 22 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index 71ceb04b33..924b0406cb 100644
--- a/configure.in
+++ b/configure.in
@@ -131,9 +131,9 @@ AC_ARG_ENABLE([shared],
[shared=default])
AC_ARG_ENABLE([profile],
AC_HELP_STRING([--enable-profile],
- [build profiled library @<:@default=no@:>@]),
+ [build profiled library @<:@default=yes@:>@]),
[profile=$enableval],
- [profile=no])
+ [profile=yes])
AC_ARG_ENABLE([omitfp],
AC_HELP_STRING([--enable-omitfp],
[build undebuggable optimized library @<:@default=no@:>@]),
@@ -1259,9 +1259,12 @@ EOF
if AC_TRY_COMMAND(${CC-cc} -c $ASFLAGS conftest.s 1>&AS_MESSAGE_LOG_FD); then
libc_cv_asm_protected_directive=yes
else
- AC_MSG_ERROR(assembler support for symbol visibility is required)
+ libc_cv_asm_protected_directive=no
fi
rm -f conftest*])
+ AC_SUBST(libc_cv_asm_protected_directive)
+ AC_DEFINE(HAVE_PROTECTED)
+ AC_DEFINE(HAVE_HIDDEN)
if test $libc_cv_asm_protected_directive = yes; then
AC_CACHE_CHECK(whether __attribute__((visibility())) is supported,
@@ -1280,8 +1283,8 @@ EOF
fi
rm -f conftest.[cs]
])
- if test $libc_cv_visibility_attribute != yes; then
- AC_MSG_ERROR(compiler support for visibility attribute is required)
+ if test $libc_cv_visibility_attribute = yes; then
+ AC_DEFINE(HAVE_VISIBILITY_ATTRIBUTE)
fi
fi
@@ -1304,7 +1307,7 @@ changequote([,])dnl
rm -f conftest.c conftest.s
])
if test $libc_cv_broken_visibility_attribute = yes; then
- AC_MSG_ERROR(working compiler support for visibility attribute is required)
+ AC_DEFINE(HAVE_BROKEN_VISIBILITY_ATTRIBUTE)
fi
fi
@@ -1328,7 +1331,7 @@ EOF
rm -f conftest.c conftest.s
])
if test $libc_cv_broken_alias_attribute = yes; then
- AC_MSG_ERROR(working alias attribute support required)
+ AC_DEFINE(HAVE_BROKEN_ALIAS_ATTRIBUTE)
fi
if test $libc_cv_visibility_attribute = yes; then
@@ -1400,9 +1403,10 @@ EOF
then
libc_cv_z_nodelete=yes
else
- AC_MSG_ERROR(linker with -z nodelete support required)
+ libc_cv_z_nodelete=no
fi
rm -f conftest*])
+ AC_SUBST(libc_cv_z_nodelete)
AC_CACHE_CHECK(for -z nodlopen option,
libc_cv_z_nodlopen, [dnl
@@ -1416,9 +1420,10 @@ EOF
then
libc_cv_z_nodlopen=yes
else
- AC_MSG_ERROR(linker with -z nodlopen support required)
+ libc_cv_z_nodlopen=no
fi
rm -f conftest*])
+ AC_SUBST(libc_cv_z_nodlopen)
AC_CACHE_CHECK(for -z initfirst option,
libc_cv_z_initfirst, [dnl
@@ -1432,16 +1437,13 @@ EOF
then
libc_cv_z_initfirst=yes
else
- AC_MSG_ERROR(linker with -z initfirst support required)
+ libc_cv_z_initfirst=no
fi
rm -f conftest*])
+ AC_SUBST(libc_cv_z_initfirst)
- case "$base_machine" in
-changequote(,)dnl
- i[34567]86 | x86_64 | powerpc* | s390* | sparc* | alpha*)
-changequote([,])dnl
- AC_CACHE_CHECK(for -z relro option,
- libc_cv_z_relro, [dnl
+ AC_CACHE_CHECK(for -z relro option,
+ libc_cv_z_relro, [dnl
libc_cv_z_relro=no
if AC_TRY_COMMAND([${CC-cc} -v --help 2>&1|grep "z relro" 1>&AS_MESSAGE_LOG_FD])
then
@@ -1450,12 +1452,10 @@ changequote([,])dnl
libc_cv_z_relro=yes
fi
fi])
- if test "$libc_cv_z_relro" = no; then
- AC_MSG_ERROR(linker with -z relro support required)
- fi
- ;;
- *) ;;
- esac
+ AC_SUBST(libc_cv_z_relro)
+ if test $libc_cv_z_relro = yes; then
+ AC_DEFINE(HAVE_Z_RELRO)
+ fi
AC_CACHE_CHECK(for -Bgroup option,
libc_cv_Bgroup, [dnl