summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>1998-03-20 12:41:37 +0000
committerUlrich Drepper <drepper@redhat.com>1998-03-20 12:41:37 +0000
commit8e31cf7e9f269668c6c86db9813839efc2fd434b (patch)
treeffb4a24232502574016ac3780e26bf578e0983ef /configure.in
parent0f648b6380ac0e9ce1be68cd5897888c19989a74 (diff)
Update.
1998-03-20 Andreas Jaeger <aj@arthur.rhein-neckar.de> * configure.in: Check for recent egcs/gcc.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index da998bca0c..cd89b421b4 100644
--- a/configure.in
+++ b/configure.in
@@ -468,6 +468,24 @@ LIBC_PROG_BINUTILS
AC_CHECK_TOOL(AR, ar)
AC_CHECK_TOOL(RANLIB, ranlib, :)
+# check for recent compiler
+AC_MSG_CHECKING(compiler version)
+case `${CC-cc} -v 2>&1` in
+ *egcs-2.91.* | *egcs-1.0.[2-9]* | *egcs-1.1* | *2.8.[1-9]* | *2.9.[0-9] )
+ cc_is_recent="ok"
+ ;;
+ *)
+ cc_is_recent="too old"
+ ;;
+esac
+AC_MSG_RESULT($cc_is_recent)
+if test $cc_is_recent != ok; then
+ AC_MSG_WARN([
+*** Your compiler is too old.
+*** You need at least egcs 1.0.2 or GNU CC 2.8.1 to compile glibc.
+])
+fi
+
AC_PATH_PROG(BASH, bash, no)
if test "$BASH" != no &&
$BASH -c 'test "$BASH_VERSINFO" \