summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2002-08-08 08:14:53 +0000
committerUlrich Drepper <drepper@redhat.com>2002-08-08 08:14:53 +0000
commit48b8e8464b5a0a4c20dca0ffac05541397bfb654 (patch)
treedca117cdd173289dba7f99acd28443a098c0af9c /configure.in
parent972e719e8154eec5f543b027e2a08dfa285d55d5 (diff)
Update.
2002-08-08 Alexandre Oliva <aoliva@redhat.com> * configure.in: Make the test for broken_alias_attribute stricter.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d2af5ab277..808e52ba97 100644
--- a/configure.in
+++ b/configure.in
@@ -1041,11 +1041,15 @@ changequote([,])dnl
[cat > conftest.c <<EOF
extern int foo (int x) __asm ("xyzzy");
int bar (int x) { return x; }
- extern __typeof (bar) foo __attribute ((weak, alias ("bar")));
+ extern __typeof (bar) foo __attribute ((weak, alias ("bar")));
+ extern int dfoo;
+ extern __typeof (dfoo) dfoo __asm ("abccb");
+ int dfoo = 1;
EOF
libc_cv_broken_alias_attribute=yes
if ${CC-cc} -Werror -S conftest.c -o conftest.s >/dev/null 2>&1; then
- if grep 'xyzzy' conftest.s >/dev/null; then
+ if grep 'xyzzy' conftest.s >/dev/null &&
+ grep 'abccb' conftest.s >/dev/null; then
libc_cv_broken_alias_attribute=no
fi
fi