summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2002-10-08 08:44:09 +0000
committerRoland McGrath <roland@gnu.org>2002-10-08 08:44:09 +0000
commit1400de2e9c706bc2ff357be7f84910723b84fb33 (patch)
tree4a0397e3eae619384abbcfd778d780fdefd90f74 /configure.in
parent44f8b0fd29027efd23d3267ffa664bc612bdb473 (diff)
2002-10-08 Roland McGrath <roland@redhat.com>
* configure.in (AUTOCONF): New check to set it. Set to "no" if the one found doesn't work on our configure.in. * configure: Regenerated. * config.make.in (AUTOCONF): New substituted variable. * Makefile (autoconf-it-cvs): New canned sequence, broken out of ... (autoconf-it): ... here, use that instead of defining conditionally. Use $(AUTOCONF) instead of literal autoconf. [$(AUTOCONF) != no] (configure, %/configure): Protect these rules with this condition. * Make-dist (autoconf-it, configure, %/configure): Copy those changes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 12a6a0f56d..d3f0f63539 100644
--- a/configure.in
+++ b/configure.in
@@ -615,6 +615,22 @@ AC_CHECK_PROG_VER(SED, sed, --version,
[3.0[2-9]*|3.[1-9]*|[4-9]*],
SED=: aux_missing="$aux_missing sed")
+AC_CHECK_PROGS(AUTOCONF, autoconf, no)
+case "x$AUTOCONF" in
+xno|x|x:) AUTOCONF=no ;;
+*)
+ AC_CACHE_CHECK(dnl
+whether $AUTOCONF${ACFLAGS:+ }$ACFLAGS works, libc_cv_autoconf_works, [dnl
+ if (cd $srcdir; $AUTOCONF $ACFLAGS configure.in > /dev/null 2>&1); then
+ libc_cv_autoconf_works=yes
+ else
+ libc_cv_autoconf_works=no
+ fi])
+ test $libc_cv_autoconf_works = yes || AUTOCONF=no
+ ;;
+esac
+test "x$AUTOCONF" != xno || aux_missing="$aux_missing autoconf"
+
AC_PROG_CC_LOCAL
AC_CANONICAL_BUILD
if test $host != $build; then