summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2001-08-03 23:04:10 +0000
committerUlrich Drepper <drepper@redhat.com>2001-08-03 23:04:10 +0000
commit5af3245a41d958c326c02e23473d44bb474602fb (patch)
treee6a145da16298ba18b815da27fb5da9c7adacf94 /configure.in
parentdb2d05f93ce7a790a1f50ed5b082539b566801e2 (diff)
Update.
2001-08-03 Tom Rix <trix@redhat.com> * config.h.in: Add HAVE_XCOFF for AIX. * configure.in: Add --with-xcoff option. * include/libc-symbols.h: Disable the .stabs macros.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e2edb389fd..177e3e4abf 100644
--- a/configure.in
+++ b/configure.in
@@ -65,6 +65,9 @@ AC_ARG_WITH(binutils, dnl
AC_ARG_WITH(elf, dnl
--with-elf if using the ELF object format,
elf=$withval, elf=no)
+AC_ARG_WITH(xcoff, dnl
+ --with-xcoff if using the XCOFF object format,
+ xcoff=$withval, xcoff=no)
AC_ARG_WITH(cvs, dnl
[ --without-cvs if CVS should not be used],
with_cvs=$withval, with_cvs=yes)
@@ -249,6 +252,11 @@ gnu* | linux* | sysv4* | solaris2* | irix6*)
# These systems (almost) always use the ELF format.
elf=yes
;;
+aix*)
+ # These systems are always xcoff
+ xcoff=yes
+ elf=no
+ ;;
esac
machine=$config_machine
@@ -1521,7 +1529,7 @@ AC_SUBST(libc_cv_rootsbindir)
AC_SUBST(use_ldconfig)
AC_SUBST(ldd_rewrite_script)
-AC_SUBST(gnu_ld) AC_SUBST(gnu_as) AC_SUBST(elf)
+AC_SUBST(gnu_ld) AC_SUBST(gnu_as) AC_SUBST(elf) AC_SUBST(xcoff)
if test $gnu_ld = yes; then
AC_DEFINE(HAVE_GNU_LD)
fi
@@ -1531,6 +1539,9 @@ fi
if test $elf = yes; then
AC_DEFINE(HAVE_ELF)
fi
+if test $xcoff = yes; then
+ AC_DEFINE(HAVE_XCOFF)
+fi
AC_SUBST(static)
AC_SUBST(shared)