summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>1998-04-09 10:14:17 +0000
committerUlrich Drepper <drepper@redhat.com>1998-04-09 10:14:17 +0000
commit73237de3761836016f67a10121ecc97a5d45cac4 (patch)
tree10145b7db278593b3becc915b147c5566840c0ae /configure.in
parent8d88d9f8aa759acc1d0b3919fa6080bb35b0f991 (diff)
Update.
1998-04-08 Andreas Schwab <schwab@issan.informatik.uni-dortmund.de> * configure.in: Add new option --enable-force-install. Substitute force_install. * config.make.in (force-install): Set from configure. * Makerules (force-install): New phony target. * Makeconfig (+force): New variable. * Makefile: Use it in dependency list of installation targets. * db/Makefile: Likewise. * db2/Makefile: Likewise. * elf/Makefile: Likewise. * hurd/Makefile: Likewise. * iconv/Makefile: Likewise. * iconvdata/Makefile: Likewise. * intl/Makefile: Likewise. * localedata/Makefile: Likewise. * login/Makefile: Likewise. * po/Makefile: Likewise. * sunrpc/Makefile: Likewise. * sysdeps/mach/hurd/Makefile: Likewise. * sysdeps/standalone/i386/force_cpu386/Makefile: Likewise. * sysdeps/unix/sysv/linux/Makefile: Likewise. * timezone/Makefile: Likewise. 1998-04-08 Andreas Schwab <schwab@issan.informatik.uni-dortmund.de> * sysdeps/unix/sysv/linux/getcwd.c: Use PATH_MAX as default alloc_size. Pass return value of getcwd syscall to realloc. 1998-04-08 Andreas Schwab <schwab@issan.informatik.uni-dortmund.de> * manual/socket.texi: Spelling fixes. 1998-04-08 Andreas Schwab <schwab@issan.informatik.uni-dortmund.de> * elf/dl-load.c (print_search_path): Remove unused variable.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 44cde5c8eb..6d17bb30cb 100644
--- a/configure.in
+++ b/configure.in
@@ -91,8 +91,9 @@ AC_ARG_ENABLE(versioning, dnl
dnl Generic infrastructure for drop-in additions to libc.
AC_ARG_ENABLE(add-ons, dnl
-[ --enable-add-ons[=DIR1,DIR2]... configure and build add-ons in DIR1,DIR2,...
- search for add-ons if no parameter given],
+[ --enable-add-ons[=DIR1,DIR2]...
+ configure and build add-ons in DIR1,DIR2,...
+ search for add-ons if no parameter given],
[case "$enableval" in
yes) if test "$srcdir" = "."; then
add_ons=`echo */configure | sed -e 's!/configure!!g'`
@@ -126,6 +127,12 @@ if test x"$static_nss" = xyes; then
AC_DEFINE(DO_STATIC_NSS)
fi
+AC_ARG_ENABLE(force-install,
+[ --enable-force-install force installation of files from this package,
+ even if they are older than the installed files],
+ force_install=$enableval, force_install=yes)
+AC_SUBST(force_install)
+
AC_CANONICAL_HOST
# The way shlib-versions is used to generate soversions.mk uses a