summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>1998-05-06 14:43:15 +0000
committerUlrich Drepper <drepper@redhat.com>1998-05-06 14:43:15 +0000
commit6600049466b586e3decaf24bd70c06b21382cf98 (patch)
tree536fc5c8efe78035527223283bcd5a48ac259576 /configure.in
parentb22fc5f5651706304ac09305ac3ee5bf84516378 (diff)
Update.
1998-04-16 07:42 Geoff Keating <geoffk@ozemail.com.au> * Makeconfig [!build-static]: Link `static' binaries with libc_pic.a. Still need *FLAGS-.o because we still sometimes build .o files. * db2/Makefile: Don't build libndbm.a if !build-static. 1998-04-16 07:42 Geoff Keating <geoffk@ozemail.com.au> * configure.in: New test for broken gcc on PowerPC. * sysdeps/powerpc/atomicity.h: Use result of test. * linuxthreads/sysdeps/powerpc/pt-machine.h: Use result of test. * math/libm-test.c: Update many of the epsilon to match actual performance. * sysdeps/libm-ieee754/e_exp.c: Reduce the number of branches. * sysdeps/libm-ieee754/e_expf.c: Likewise. * sysdeps/libm-ieee754/s_exp2.c: Likewise. * sysdeps/libm-ieee754/s_exp2f.c: Likewise. * sysdeps/libm-ieee754/e_pow.c: Correct typo. * sysdeps/powerpc/elf/libc-start.c: New file. * sysdeps/powerpc/elf/start.S: New file, use libc-start. * sysdeps/powerpc/elf/start.c: Delete. * sysdeps/unix/sysv/linux/powerpc/Dist: Remove syscall.h * sysdeps/unix/sysv/linux/powerpc/syscall.h: Delete. It was unused. * sysdeps/unix/sysv/linux/powerpc/dl-sysdep.c: Correct previous few patches.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e7dfcc59a3..9866d4b8aa 100644
--- a/configure.in
+++ b/configure.in
@@ -921,6 +921,18 @@ else
fi
fi
+if test "$host_cpu" = powerpc ; then
+# Check for a bug present in at least versions 2.8.x of GCC
+# and versions 1.0.x of EGCS.
+AC_CACHE_CHECK(whether clobbering cr0 causes problems,libc_cv_c_asmcr0_bug,[dnl
+AC_TRY_COMPILE([int tester(int x) { asm ("" : : : "cc"); return x & 123; }],,
+ libc_cv_c_asmcr0_bug='no',
+ libc_cv_c_asmcr0_bug='yes')])
+if test "$libc_cv_c_asmcr0_bug" != 'no'; then
+ AC_DEFINE(BROKEN_PPC_ASM_CR0)
+fi
+fi
+
AC_CACHE_CHECK(for DWARF2 unwind info support, libc_cv_gcc_dwarf2_unwind_info,
[cat > conftest.c <<EOF
#line __oline__ "configure"