summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndreas Schwab <schwab@linux-m68k.org>2009-05-31 16:54:28 -0700
committerPetr Baudis <pasky@suse.cz>2009-06-05 23:05:50 +0200
commit10bf3b765521cf6f8bc30efcfbf6f16debcbce8e (patch)
tree602237af699072768182ef722164c5dfed782fa3 /configure.in
parent8eccea8011d27503c02b1dcd00aef80185e1b89a (diff)
Move AC_CANONICAL_HOST before first use of $host and $build.
(cherry picked from commit c16a054d5e20e4da6ccc528b690910a777d69a8b)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d54e952d91..6a92bd876a 100644
--- a/configure.in
+++ b/configure.in
@@ -6,6 +6,8 @@ AC_CONFIG_SRCDIR([include/features.h])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_AUX_DIR([scripts])
+AC_CANONICAL_HOST
+
AC_PROG_CC
if test $host != $build; then
AC_CHECK_PROGS(BUILD_CC, gcc cc)
@@ -316,8 +318,6 @@ else
fi
AC_SUBST(libc_cv_nss_crypt)
-AC_CANONICAL_HOST
-
# The way shlib-versions is used to generate soversions.mk uses a
# fairly simplistic model for name recognition that can't distinguish
# i486-pc-linux-gnu fully from i486-pc-gnu. So we mutate a $host_os