summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2015-10-26 22:46:04 +0000
committerJoseph Myers <joseph@codesourcery.com>2015-10-26 22:46:04 +0000
commitf5659917f9cbdbd162870b858e527506687bfb1f (patch)
treee4c861dd939b329e63ef5551cd2c321e89d22975 /configure.ac
parent8c0c01dbe70e00b6b85425d0c5c22b30bd2fc1ac (diff)
Remove support for removing glibc 2.0 headers.
There is a configure test for the presence of glibc 2.0 headers (that were renamed / no longer installed in glibc 2.1) and associated support for removing them on "make install". Normal practice for subsequent removal / renaming of installed files has been not to do anything special about removing them; if you want installed files from an old installation removed reliably, you need to use a packaging system that tracks what files were installed by a previous glibc package (via installing in an intermediate directory with install_root). I think it's been long enough since 2.0 that it's not particularly useful to have that special logic for those old headers either; this patch removes it. Tested for x86_64 and x86 (testsuite, and that installed shared libraries are unchanged by the patch). * configure.ac (old_glibc_headers): Remove configure test. * configure: Regenerated. * config.make.in (old-glibc-headers): Remove variable. * Makefile [!$(install_root) && $(old-glibc-headers) = yes] (install): Remove dependency on remove-old-headers. (headers2_0): Remove variable. (remove-old-headers): Remove rule.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 023f132ad3..6947555be4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1899,22 +1899,6 @@ if test "x$build_nscd" = xdefault; then
build_nscd=$use_nscd
fi
-# Test for old glibc 2.0.x headers so that they can be removed properly
-# Search only in includedir.
-AC_MSG_CHECKING(for old glibc 2.0.x headers)
-if eval test -f "${includedir}/elfclass.h" -a -f "${includedir}/fcntlbits.h"
-then
- old_glibc_headers=yes
-else
- old_glibc_headers=no
-fi
-AC_MSG_RESULT($old_glibc_headers)
-if test ${old_glibc_headers} = yes; then
- AC_MSG_WARN(*** During \"make install\" old headers from glibc 2.0.x will)
- AC_MSG_WARN(*** be removed.)
-fi
-AC_SUBST(old_glibc_headers)
-
AC_SUBST(libc_cv_slibdir)
AC_SUBST(libc_cv_rtlddir)
AC_SUBST(libc_cv_localedir)