summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Thibault <samuel.thibault@ens-lyon.org>2015-02-11 23:27:50 +0000
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2015-02-11 23:51:51 +0000
commitebf27d12e602b428a316c105ed10371ed84d2d3d (patch)
treeff0418d6c09e8651bf01c70e42ce428c93674e19 /configure.ac
parentd435569cd626bccb9c27361202a279d0fd7fce88 (diff)
Revert "hurd: Fix abi-tag, following ba90e05"
and revert the corresponding part of ba90e05 which was making the fix necessary. * abi-tags: Revert ae20c9a: rename back gnu into gnu-gnu. * configure.ac, configure: Revert ba90e05: modify gnu-* host_os back into gnu-gnu, and update comment to refer to abi-tags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d89aaf0cdf..8043a27c3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -360,6 +360,18 @@ if test "$build_pt_chown" = yes; then
AC_DEFINE(HAVE_PT_CHOWN)
fi
+# The abi-tags file uses a fairly simplistic model for name recognition that
+# can't distinguish i486-pc-linux-gnu fully from i486-pc-gnu. So we mutate a
+# $host_os of `gnu*' here to be `gnu-gnu*' just so that it can tell.
+# This doesn't get used much beyond that, so it's fairly safe.
+case "$host_os" in
+linux*)
+ ;;
+gnu*)
+ host_os=`echo $host_os | sed -e 's/gnu/gnu-gnu/'`
+ ;;
+esac
+
# We keep the original values in `$config_*' and never modify them, so we
# can write them unchanged into config.make. Everything else uses
# $machine, $vendor, and $os, and changes them whenever convenient.