summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2015-10-27 10:46:15 +0000
committerJoseph Myers <joseph@codesourcery.com>2015-10-27 10:46:15 +0000
commite4f5eae8f004f236db11325df2adf338766c0543 (patch)
tree5de6d64665e7beeb7b755ed170521ce18ec1cf09 /configure.ac
parentf5659917f9cbdbd162870b858e527506687bfb1f (diff)
Remove configure test for needing -P for .S files.
There is a configure test for "whether we need to use -P to assemble .S files". I think this test is long obsolete. I don't have a specific reference to a binutils change or version that obsoleted this test, but: (a) we only support GNU binutils; (b) it looks like every architecture supported by glibc has '#' as a line comment character in its gas port; (c) in any case, if the (compiler, assembler) combination in use cannot compile a .S file without special options, that would clearly be a substantially broken combination, which I don't think we need to allow for at all. The test in question was added by: Thu Jan 27 16:46:03 1994 Roland McGrath (roland@churchy.gnu.ai.mit.edu) * configure.in (asm-CPPFLAGS): Add new check to see if assembling a .S file loses without -P. If so, set asm-CPPFLAGS=-P in config.make. This patch removes the test and the reference to this issue in the comment on the default empty definition of asm-CPPFLAGS. (Various other settings of asm-CPPFLAGS remain in sysdeps Makefile fragments.) Tested for x86_64 and x86 (testsuite, and that installed shared libraries are unchanged by the patch). * configure.ac (libc_cv_need_minus_P): Remove configure test. * configure: Regenerated. * Makeconfig (asm-CPPFLAGS): Remove reference to -P in comment.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 6947555be4..4879c48db7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1080,23 +1080,6 @@ AC_CHECK_PROG_VER(BISON, bison, --version,
[2.7*|[3-9].*|[1-9][0-9]*],
BISON=no)
-AC_CACHE_CHECK(whether we need to use -P to assemble .S files,
- libc_cv_need_minus_P, [dnl
-cat > conftest.S <<EOF
-#include "confdefs.h"
-/* Nothing whatsoever. */
-EOF
-if AC_TRY_COMMAND(${CC-cc} $CPPFLAGS $ASFLAGS -c conftest.S 1>&AS_MESSAGE_LOG_FD); then
- libc_cv_need_minus_P=no
-else
- libc_cv_need_minus_P=yes
-fi
-rm -f conftest*])
-if test $libc_cv_need_minus_P = yes; then
- config_vars="$config_vars
-asm-CPPFLAGS = -P # The assembler can't grok cpp's # line directives."
-fi
-
AC_CACHE_CHECK(for .set assembler directive, libc_cv_asm_set_directive, [dnl
cat > conftest.s <<EOF
.text