summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2015-11-02 15:08:25 +0000
committerJoseph Myers <joseph@codesourcery.com>2015-11-02 15:08:25 +0000
commita9224562cbe9cfb0bd8d9e637a06141141f9e6e3 (patch)
tree143448c101a07126967a74cffa1cc529121a1ac0 /configure.ac
parentaf1b2fd08388a3beec3ee7eaa30646d9c002824e (diff)
Remove init_array / fini_array configure test.
There is a configure test "for .preinit_array/.init_array/.fini_array support". Support for this feature was added in binutils 2.13, so the configure test is obsolete; this patch removes it. Tested for x86_64 and x86 (testsuite, and that installed shared libraries are unchanged by the patch). * configure.ac (libc_cv_initfini_array): Remove configure test. * configure: Regenerated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 6a56826516..d4aa67fb74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1161,23 +1161,6 @@ if test $libc_cv_have_sdata_section = yes; then
AC_DEFINE(HAVE_SDATA_SECTION)
fi
-AC_CACHE_CHECK(for .preinit_array/.init_array/.fini_array support,
- libc_cv_initfini_array, [dnl
-LIBC_TRY_LINK_STATIC([
-int foo (void) { return 1; }
-int (*fp) (void) __attribute__ ((section (".init_array"))) = foo;
-],
- [if $READELF -S conftest | fgrep INIT_ARRAY > /dev/null; then
- libc_cv_initfini_array=yes
- else
- libc_cv_initfini_array=no
- fi],
- [libc_cv_initfini_array=no])
-])
-if test $libc_cv_initfini_array != yes; then
- AC_MSG_ERROR([Need linker with .init_array/.fini_array support.])
-fi
-
AC_CACHE_CHECK(whether to use .ctors/.dtors header and trailer,
libc_cv_ctors_header, [dnl
libc_cv_ctors_header=yes