summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2015-10-26 22:44:18 +0000
committerJoseph Myers <joseph@codesourcery.com>2015-10-26 22:44:18 +0000
commit8c0c01dbe70e00b6b85425d0c5c22b30bd2fc1ac (patch)
tree3496d3751ae38930a37772119d55fef7753b2a8d /configure.ac
parente39edb0552323e32a70ea4cf34137cf141ccebfd (diff)
Remove configure test for assembler .text directive.
There is a configure test for assembler support for the .text directive. I suppose this test must have been aimed at some non-ELF platform or non-GNU assembler. Certainly the GNU assembler has had ELF-specific architecture-independent handling for .text since version 2.2, and generic non-ELF-specific support predates that. This patch removes this test as obsolete. Tested for x86_64 and x86 (testsuite, and that installed shared libraries are unchanged by the patch). * configure.ac (libc_cv_dot_text): Remove configure test. (libc_cv_asm_set_directive): Use .text instead of ${libc_cv_dot_text} in configure test. * configure: Regenerated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 1 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 3c7f6c0096..023f132ad3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -635,22 +635,6 @@ if ${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS \
fi
rm -f conftest*])
-AC_MSG_CHECKING(whether .text pseudo-op must be used)
-AC_CACHE_VAL(libc_cv_dot_text, [dnl
-cat > conftest.s <<EOF
-.text
-EOF
-libc_cv_dot_text=
-if AC_TRY_COMMAND(${CC-cc} $ASFLAGS -c conftest.s 1>&AS_MESSAGE_LOG_FD); then
- libc_cv_dot_text=.text
-fi
-rm -f conftest*])
-if test -z "$libc_cv_dot_text"; then
- AC_MSG_RESULT(no)
-else
- AC_MSG_RESULT(yes)
-fi
-
if test x"$libc_cv_ld_gnu_indirect_function" != xyes; then
if test x"$multi_arch" = xyes; then
AC_MSG_ERROR([--enable-multi-arch support requires assembler and linker support])
@@ -1115,7 +1099,7 @@ fi
AC_CACHE_CHECK(for .set assembler directive, libc_cv_asm_set_directive, [dnl
cat > conftest.s <<EOF
-${libc_cv_dot_text}
+.text
foo:
.set glibc_conftest_frobozz,foo
.globl glibc_conftest_frobozz