summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2015-10-15 19:47:55 +0000
committerJoseph Myers <joseph@codesourcery.com>2015-10-15 19:47:55 +0000
commit75b0964bc8f00400056449eceb8ab57c8eb3fde2 (patch)
treec78a7cc6861f1bd061197a1f9a905c760467c09d /configure.ac
parent30f58bb19238bfc5f617978f3201c2c42d2828f4 (diff)
Remove .previous, .popsection configure tests.
There is a configure test for the assembler .previous directive, and, as a fallback, for .popsection. glibc now only supports ELF. For ELF, the GNU assembler has supported .previous since version 2.2 (support added by Mon Jul 19 15:21:20 1993 Ken Raeburn (raeburn@rtl.cygnus.com) * config/obj-elf.c (obj_elf_previous): New function. (previous_section, previous_subsection): New vars. (obj_elf_section): Save current place in case DWARF code wants us to pop back to it. Handle unquoted section name as well as quoted section name. Don't crash on invalid strings. (obj_pseudo_table): Handle new pseudos "previous", "2byte", and "4byte". ). Thus this configure test is obsolete, and this patch removes it (and with it the fallback .popsection test). Tested for x86_64 and x86 (testsuite, and that installed shared libraries are unchanged by the patch). * configure.ac (libc_cv_asm_previous_directive): Remove configure test. (libc_cv_asm_popsection_directive): Likewise. * configure: Regenerated. * config.h.in (HAVE_ASM_PREVIOUS_DIRECTIVE): Remove #undef. (HAVE_ASM_POPSECTION_DIRECTIVE): Likewise. * include/libc-symbols.h [HAVE_ASM_PREVIOUS_DIRECTIVE] (__make_section_unallocated): Make definition unconditional. [HAVE_ASM_POPSECTION_DIRECTIVE] (__make_section_unallocated): Remove conditional definition. [!HAVE_ASM_PREVIOUS_DIRECTIVE && !HAVE_ASM_POPSECTION_DIRECTIVE] (__make_section_unallocated): Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 0 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 047c6322a3..384bf3f152 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1138,37 +1138,6 @@ if test $libc_cv_asm_unique_object = yes; then
AC_DEFINE(HAVE_ASM_UNIQUE_OBJECT)
fi
-AC_CACHE_CHECK(for .previous assembler directive,
- libc_cv_asm_previous_directive, [dnl
-cat > conftest.s <<EOF
-.section foo_section
-.previous
-EOF
-if AC_TRY_COMMAND(${CC-cc} -c $ASFLAGS conftest.s 1>&AS_MESSAGE_LOG_FD); then
- libc_cv_asm_previous_directive=yes
-else
- libc_cv_asm_previous_directive=no
-fi
-rm -f conftest*])
-if test $libc_cv_asm_previous_directive = yes; then
- AC_DEFINE(HAVE_ASM_PREVIOUS_DIRECTIVE)
-else
- AC_CACHE_CHECK(for .popsection assembler directive,
- libc_cv_asm_popsection_directive, [dnl
- cat > conftest.s <<EOF
-.pushsection foo_section
-.popsection
-EOF
- if AC_TRY_COMMAND(${CC-cc} -c $ASFLAGS conftest.s 1>&AS_MESSAGE_LOG_FD); then
- libc_cv_asm_popsection_directive=yes
- else
- libc_cv_asm_popsection_directive=no
- fi
- rm -f conftest*])
- if test $libc_cv_asm_popsection_directive = yes; then
- AC_DEFINE(HAVE_ASM_POPSECTION_DIRECTIVE)
- fi
-fi
AC_CACHE_CHECK(for .protected and .hidden assembler directive,
libc_cv_asm_protected_directive, [dnl
cat > conftest.s <<EOF