summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2015-10-15 19:32:58 +0000
committerJoseph Myers <joseph@codesourcery.com>2015-10-15 19:32:58 +0000
commit30f58bb19238bfc5f617978f3201c2c42d2828f4 (patch)
treedab6915641e96726e62b0700ded22bea25da7dc4 /configure.ac
parent06e2c646693d5310011c0190509682a23097b8ae (diff)
Remove -static-libgcc configure test.
There is a configure test for -static-libgcc. GCC added this option in version 3.0, so this test is obsolete; this patch removes it. Tested for x86_64 and x86 (testsuite, and that installed shared libraries are unchanged by the patch). * configure.ac (libc_cv_gcc_static_libgcc): Remove configure test. * configure: Regenerated. * config.make.in (static-libgcc): Remove variable. * Makerules (build-shlib-helper): Use -static-libgcc instead of $(static-libgcc). (build-module-helper): Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index e2112f3c54..047c6322a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1065,14 +1065,6 @@ AC_MSG_ERROR([
*** and run configure again.])
fi
-AC_CACHE_CHECK(whether GCC supports -static-libgcc, libc_cv_gcc_static_libgcc, [dnl
-if $CC -v -static-libgcc 2>&1 | grep 'unrecognized option.*static-libgcc' >/dev/null; then
- libc_cv_gcc_static_libgcc=
-else
- libc_cv_gcc_static_libgcc=-static-libgcc
-fi])
-AC_SUBST(libc_cv_gcc_static_libgcc)
-
AC_PATH_PROG(BASH_SHELL, bash, no)
AC_PATH_PROG(PERL, perl, no)