summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2015-10-15 23:36:22 +0000
committerJoseph Myers <joseph@codesourcery.com>2015-10-15 23:36:22 +0000
commit2b714df5d8977132b6bd8a2b338b1a523bb00d9f (patch)
tree69064bac92c45416abcb00447bac1ce8070b8df9 /configure.ac
parent3d0dbdc46710c262bf4fc4786b32d61bd777b33b (diff)
Remove -Bgroup configure test.
There is a configure test for the -Bgroup linker option whose results aren't used anywhere. This patch removes that test. Tested for x86_64 (testsuite, and that installed shared libraries are unchanged by the patch). * configure.ac (libc_cv_Bgroup): Remove configure test. * configure: Regenerated. * config.make.in (have-Bgroup): Remove variable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 7d94d9f35a..402de30b87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1336,22 +1336,6 @@ LIBC_LINKER_FEATURE([-z initfirst], [-Wl,--enable-new-dtags,-z,initfirst],
[libc_cv_z_initfirst=yes],
[AC_MSG_ERROR(linker with -z initfirst support required)])
-AC_CACHE_CHECK(for -Bgroup option,
- libc_cv_Bgroup, [dnl
-cat > conftest.c <<EOF
-int _start (void) { return 42; }
-EOF
-if AC_TRY_COMMAND([${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS
- -fPIC -shared -o conftest.so conftest.c
- -Wl,-Bgroup -nostdlib 1>&AS_MESSAGE_LOG_FD])
-then
- libc_cv_Bgroup=yes
-else
- libc_cv_Bgroup=no
-fi
-rm -f conftest*])
-AC_SUBST(libc_cv_Bgroup)
-
ASFLAGS_config=
AC_CACHE_CHECK(whether --noexecstack is desirable for .S files,
libc_cv_as_noexecstack, [dnl