summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2015-10-19 12:06:00 +0000
committerJoseph Myers <joseph@codesourcery.com>2015-10-19 12:06:00 +0000
commit210dd78238dc99d1ba27318bf81393237620b72b (patch)
tree495b34518e631e287c5e6216375f31a8de6b5ca8 /configure.ac
parentbd2260a2069993cdb14cffcbb2b0dc04b9888aee (diff)
Remove .weak, .weakext configure tests.
There are configure tests for assembler .weak support, and, as a fallback, for .weakext support. .weakext appears to be an ECOFF thing (although a few ELF targets support it as well). .weak has been supported by the GNU assembler for ELF targets since version 2.2, so given the requirement for ELF the configure tests are obsolete; this patch removes them. Tested for x86_64 (testsuite, and that installed shared libraries are unchanged by the patch). * configure.ac (libc_cv_asm_weak_directive): Remove configure test. (libc_cv_asm_weakext_directive): Likewise. * configure: Regenerated. * config.h.in (HAVE_ASM_WEAK_DIRECTIVE): Remove #undef. (HAVE_ASM_WEAKEXT_DIRECTIVE): Likewise. * include/libc-symbols.h [!HAVE_ASM_WEAK_DIRECTIVE && !HAVE_ASM_WEAKEXT_DIRECTIVE]: Remove #error. [HAVE_ASM_WEAKEXT_DIRECTIVE]: Remove conditional code. [!HAVE_ASM_WEAKEXT_DIRECTIVE]: Make code unconditional.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 0 insertions, 44 deletions
diff --git a/configure.ac b/configure.ac
index 402de30b87..14f5c170d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1550,50 +1550,6 @@ if test $libc_cv_have_section_quotes = yes; then
AC_DEFINE(HAVE_SECTION_QUOTES)
fi
-AC_CACHE_CHECK(for assembler .weak directive, libc_cv_asm_weak_directive,
- [dnl
-cat > conftest.s <<EOF
-${libc_cv_dot_text}
-.globl foo
-foo:
-.weak foo
-.weak bar; bar = foo
-EOF
-if AC_TRY_COMMAND(${CC-cc} $ASFLAGS -c conftest.s 1>&AS_MESSAGE_LOG_FD); then
- libc_cv_asm_weak_directive=yes
-else
- libc_cv_asm_weak_directive=no
-fi
-rm -f conftest*])
-
-if test $libc_cv_asm_weak_directive = no; then
- AC_CACHE_CHECK(for assembler .weakext directive,
- libc_cv_asm_weakext_directive,
- [dnl
-cat > conftest.s <<EOF
-${libc_cv_dot_text}
-.globl foo
-foo:
-.weakext bar foo
-.weakext baz
-.globl baz
-baz:
-EOF
- if AC_TRY_COMMAND(${CC-cc} $ASFLAGS -c conftest.s 1>&AS_MESSAGE_LOG_FD); then
- libc_cv_asm_weakext_directive=yes
- else
- libc_cv_asm_weakext_directive=no
- fi
- rm -f conftest*])
-
-fi # no .weak
-
-if test $libc_cv_asm_weak_directive = yes; then
- AC_DEFINE(HAVE_ASM_WEAK_DIRECTIVE)
-elif test $libc_cv_asm_weakext_directive = yes; then
- AC_DEFINE(HAVE_ASM_WEAKEXT_DIRECTIVE)
-fi
-
AC_CACHE_CHECK(for ld --no-whole-archive, libc_cv_ld_no_whole_archive, [dnl
cat > conftest.c <<\EOF
_start () {}