summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-09-18 14:00:05 -0400
committerMike Frysinger <vapier@gentoo.org>2015-09-18 19:39:46 -0400
commit1cba4036b6f5e798114c7cc77c788839c89e3b3c (patch)
tree7c399ad0e7a357d82cc5aeec35e03c4419c2ada9 /configure.ac
parent36546ffbef5d4f5ea0f5d5c8e3fe5a5c9a34ea47 (diff)
timezone: add a configure flag to disable program install
Some distros build+install the timezone tools (zic/zdump/tzselect) outside of glibc and use the upstream package directly. Add a configure flag to glibc so they can disable install of those tools. This allows tests to run & pass regardless of the configure flag. Only the install of them is impacted.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7e9383a7f0..95d700e835 100644
--- a/configure.ac
+++ b/configure.ac
@@ -159,6 +159,12 @@ AC_ARG_ENABLE([profile],
[build profiled library @<:@default=no@:>@]),
[profile=$enableval],
[profile=no])
+AC_ARG_ENABLE([timezone-tools],
+ AC_HELP_STRING([--disable-timezone-tools],
+ [do not install timezone tools (if using external ones) @<:@default=install@:>@]),
+ [enable_timezone_tools=$enableval],
+ [enable_timezone_tools=yes])
+AC_SUBST(enable_timezone_tools)
AC_ARG_ENABLE([hardcoded-path-in-tests],
AC_HELP_STRING([--enable-hardcoded-path-in-tests],