summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2015-10-15 19:31:46 +0000
committerJoseph Myers <joseph@codesourcery.com>2015-10-15 19:31:46 +0000
commit06e2c646693d5310011c0190509682a23097b8ae (patch)
treeb8aaafe1ce079013b0c9928563b78b95ced86f72 /configure.ac
parent95e83974812f5c6de0483690ef47787965bb817a (diff)
Remove stddef.h configure test.
There is a configure test "for libc-friendly stddef.h", which sets a makefile variable stddef.h that appears to be nowhere used. It appears the uses of this variable were removed by: Tue Feb 21 00:10:50 1995 Roland McGrath <roland@churchy.gnu.ai.mit.edu> * Makefile (headers): Remove $(stddef.h). * Makeconfig (stddef.h): Variable removed; now require gcc version >= 2.2. * stddef.h: File removed. (having been added by Wed May 26 14:44:19 1993 Roland McGrath (roland@churchy.gnu.ai.mit.edu) * configure.in (autoconf checks): Add new check for a libc-friendly stddef.h. so the test was of use for less than two years, before being obsolete for over 20 years). This patch removes the test. Tested for x86_64 and x86 (testsuite, and that installed shared libraries are unchanged by the patch). * configure.ac (libc_cv_friendly_stddef): Remove configure test. * configure: Regenerated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 0 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 75a3a77677..e2112f3c54 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1087,24 +1087,6 @@ AC_CHECK_PROG_VER(BISON, bison, --version,
[2.7*|[3-9].*|[1-9][0-9]*],
BISON=no)
-AC_CACHE_CHECK(for libc-friendly stddef.h, libc_cv_friendly_stddef, [dnl
-AC_TRY_COMPILE(dnl
-[#define __need_size_t
-#define __need_wchar_t
-#include <stddef.h>
-#define __need_NULL
-#include <stddef.h>], [size_t size; wchar_t wchar;
-#ifdef offsetof
-#error stddef.h ignored __need_*
-#endif
-if (&size == NULL || &wchar == NULL) abort ();],
- libc_cv_friendly_stddef=yes,
- libc_cv_friendly_stddef=no)])
-if test $libc_cv_friendly_stddef = yes; then
- config_vars="$config_vars
-override stddef.h = # The installed <stddef.h> seems to be libc-friendly."
-fi
-
AC_CACHE_CHECK(whether we need to use -P to assemble .S files,
libc_cv_need_minus_P, [dnl
cat > conftest.S <<EOF