summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2014-06-26 17:34:27 +0000
committerJoseph Myers <joseph@codesourcery.com>2014-06-26 17:34:27 +0000
commite64708de3674314ee73a490d9d3e36b59e61612a (patch)
treebba202492eb12576ff98403fe460973c81cd98d0 /configure.ac
parenta8779c28a8172b6573c9dd1724540e679c77168c (diff)
Remove powerpc special cases in configure.ac.
This patch removes two powerpc special cases in the main configure.ac. The test for rs6000 is irrelevant to currently supported configurations (config.guess reports rs6000 for some OSes, of which the only one currently supported by GCC is AIX, but not for Linux). There's no need either for a special case for powerpc*-*soft; --without-fp suffices, and GCC doesn't have any special handling of such a triplet. Not tested. * configure.ac: Do not test for machine being rs6000. Do not test for powerpc*-*soft. * configure: Regenerated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 22c2b4c376..f8d78608c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -398,19 +398,6 @@ vendor=$config_vendor
os=$config_os
base_os=''
-# config.guess on some IBM machines says `rs6000' instead of `powerpc'.
-# Unify this here.
-if test "$machine" = rs6000; then
- machine="powerpc"
-fi
-
-# Braindead PowerPC box with absolutely no FPU.
-case "$machine-$host_os" in
- powerpc*-*soft)
- with_fp=no
- ;;
-esac
-
submachine=
AC_ARG_WITH([cpu],
AS_HELP_STRING([--with-cpu=CPU], [select code for CPU variant]),