summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWill Newton <will.newton@linaro.org>2014-12-11 17:27:34 +0000
committerWill Newton <will.newton@linaro.org>2014-12-22 11:57:40 +0000
commitcc8623f196cd5d1c82573b34cb3a6a56f712790a (patch)
treebae68fcd9421e593a075b1ce270261b62dfd1791 /configure.ac
parente969965afdeab1144ace665f28273f5f543923b2 (diff)
Require bison 2.7 or newer for regenerating intl/plural.y
The merge of the latest gettext code introduced changes to the yacc parser source that are incompatible with versions of bison older than 2.7. Add a configure check for the appropriate versions and document the requirement in INSTALL. ChangeLog: 2014-12-22 Will Newton <will.newton@linaro.org> * manual/install.texi: Document that we require bison 2.7 or above. * INSTALL: Regenerate. * configure.ac: Use AC_CHECK_PROG_VER instead of AC_PATH_PROG when checking for bison and check for version 2.7 or above. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f1e6394e7e..d89aaf0cdf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1048,7 +1048,10 @@ if test "$PERL" != no &&
fi
AC_PATH_PROG(INSTALL_INFO, install-info, no,
$PATH:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin)
-AC_PATH_PROG(BISON, bison, no, $PATH:/usr/local/bin:/usr/bin:/bin)
+AC_CHECK_PROG_VER(BISON, bison, --version,
+ [bison (GNU Bison) \([0-9]*\.[0-9.]*\)],
+ [2.7*|[3-9].*|[1-9][0-9]*],
+ BISON=no)
AC_CACHE_CHECK(for libc-friendly stddef.h, libc_cv_friendly_stddef, [dnl
AC_TRY_COMPILE(dnl