summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2014-06-25 17:54:44 +0000
committerJoseph Myers <joseph@codesourcery.com>2014-06-25 17:54:44 +0000
commit92072d57c6754a4874f673439bc2b5a30f4c8918 (patch)
treecd13c0c09c722a92dd2423e093971a734ba14197 /configure.ac
parent3e239be647036760563e62639ea574a2c55b9191 (diff)
Remove BROKEN_PPC_ASM_CR0 configure test.
One piece of architecture-specific code in the main configure.ac is the powerpc test that can define BROKEN_PPC_ASM_CR0. There's no need to move this to a sysdeps configure script, or to work out what bug it was testing in May 1998 to see if it's still relevant, since nothing in the source tree now uses the results of this test. Thus, this patch just removes the test in question. Not tested. * configure.ac (libc_cv_c_asmcr0_bug): Remove configure test. * configure: Regenerated. * config.h.in (BROKEN_PPC_ASM_CR0): Remove macro.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 2d5b902a49..589b3d053c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1763,18 +1763,6 @@ if test $libc_cv_gcc_exceptions = yes; then
fi
AC_SUBST(exceptions)dnl
-if test "$host_cpu" = powerpc ; then
-# Check for a bug present in at least versions 2.8.x of GCC
-# and versions 1.0.x of EGCS.
-AC_CACHE_CHECK(whether clobbering cr0 causes problems,libc_cv_c_asmcr0_bug,[dnl
-AC_TRY_COMPILE([int tester(int x) { asm ("" : : : "cc"); return x & 123; }],,
- libc_cv_c_asmcr0_bug='no',
- libc_cv_c_asmcr0_bug='yes')])
-if test "$libc_cv_c_asmcr0_bug" != 'no'; then
- AC_DEFINE(BROKEN_PPC_ASM_CR0)
-fi
-fi
-
AC_CACHE_CHECK(for __builtin_memset, libc_cv_gcc_builtin_memset, [dnl
cat > conftest.c <<\EOF
void zero (void *x)