summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdhemerval Zanella <azanella@linux.vnet.ibm.com>2014-04-06 16:26:32 -0500
committerAdhemerval Zanella <azanella@linux.vnet.ibm.com>2014-04-06 16:48:08 -0500
commit7ffa9423020fe331b45a56b804c95929a0398e8b (patch)
tree2db5161018046fbcf34bd145c5095765dec6f3c1 /configure.ac
parent8bd70862e11023e7f827f240a5a214f847ae982d (diff)
PowerPC: define _CALL_ELF if compiler does not
This patch makes the configure adds -D_CALL_ELF=1 when compiler does not define _CALL_ELF (versions before powerpc64le support). It cleans up compiler warnings on old compiler where _CALL_ELF is not defined on powerpc64(be) builds. It does by add a new config.make variable for configure-deduced CPPFLAGS and accumulate into that (confix-extra-cppflags). It also generalizes libc_extra_cflags so it accumulates in sysdeps configure fragmenets.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 43bd8a5303..629187232f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2042,9 +2042,9 @@ esac],
])
libc_extra_cflags=
if test $libc_cv_predef_stack_protector = yes; then
- libc_extra_cflags=-fno-stack-protector
+ libc_extra_cflags="$libc_extra_cflags -fno-stack-protector"
fi
-AC_SUBST(libc_extra_cflags)
+libc_extra_cppflags=
AC_CACHE_CHECK([whether the linker provides __ehdr_start],
libc_cv_ehdr_start, [
@@ -2091,6 +2091,9 @@ for dir in $sysnames; do
fi
done
+AC_SUBST(libc_extra_cflags)
+AC_SUBST(libc_extra_cppflags)
+
if test x$libc_cv_gcc_unwind_find_fde = xyes; then
AC_DEFINE(EXPORT_UNWIND_FIND_FDE)
fi