summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillem Jover <guillem@hadrons.org>2011-08-30 03:14:19 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2011-08-30 22:47:50 +0200
commit41fd7888dc98d596c0e42aa3e049294e8198dd7a (patch)
treeb180f57b9ecc1692972c771c1fe4b1ef9f405ecc /configure.ac
parentc97f8cee5fc502ec200708161c8645f5da167e5f (diff)
Add silent rules support if available and disable it by default
* configure.ac (AM_SILENT_RULES): Add silent rules support if available, and disable it by default. * Makefile.am (AWK_V, AWK_V_, AWK_V_0): New variables. (.sym.symc): Use AWK_V in front of AWK. (.symc.symo): Use AM_V_CC in front of TARGET_CC. (.symo.h): Use AM_V_GEN in front of sed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b78a71a..4b2852e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,9 @@ dnl Don't define `PACKAGE' and `VERSION'.
[no-define]
)
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([no])],
+ [AC_SUBST([AM_DEFAULT_VERBOSITY], [1])])
+
dnl Checks for programs.
AC_PROG_CC
AC_PROG_CPP