summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuillem Jover <guillem@hadrons.org>2011-08-30 03:14:19 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2011-08-30 22:47:50 +0200
commit41fd7888dc98d596c0e42aa3e049294e8198dd7a (patch)
treeb180f57b9ecc1692972c771c1fe4b1ef9f405ecc /Makefile.am
parentc97f8cee5fc502ec200708161c8645f5da167e5f (diff)
Add silent rules support if available and disable it by default
* configure.ac (AM_SILENT_RULES): Add silent rules support if available, and disable it by default. * Makefile.am (AWK_V, AWK_V_, AWK_V_0): New variables. (.sym.symc): Use AWK_V in front of AWK. (.symc.symo): Use AM_V_CC in front of TARGET_CC. (.symo.h): Use AM_V_GEN in front of sed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 5de3fde..a28fa3e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,10 @@ EXTRA_DIST = gensym.awk cpu.sym
CLEANFILES = cpu.h *.sym[co]
+AWK_V = $(AWK_V_$(V))
+AWK_V_ = $(AWK_V_$(AM_DEFAULT_VERBOSITY))
+AWK_V_0 = @echo " AWK $@";
+
migcom_SOURCES = alloc.h boolean.h error.c error.h global.c global.h \
header.c lexxer.h lexxer.l message.h mig_string.h \
migcom.c parser.h parser.y routine.c routine.h \
@@ -17,11 +21,11 @@ migcom_LDADD = @ALLOCA@ @LEXLIB@
SUFFIXES = .h .symo .symc .sym
.sym.symc:
- $(AWK) -f $(srcdir)/gensym.awk $< > $@
+ $(AWK_V) $(AWK) -f $(srcdir)/gensym.awk $< > $@
.symc.symo:
- $(TARGET_CC) -S $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -x c -o $@ $<
+ $(AM_V_CC) $(TARGET_CC) -S $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -x c -o $@ $<
.symo.h:
- sed -e '/^[^*].*$$/d' -e 's/^[*]/#define/' -e 's/mAgIc[^-0-9]*//' \
+ $(AM_V_GEN) sed -e '/^[^*].*$$/d' -e 's/^[*]/#define/' -e 's/mAgIc[^-0-9]*//' \
$< > $@
cpu.symc: $(srcdir)/gensym.awk