summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Braun <rbraun@sceen.net>2018-01-04 21:50:05 +0100
committerRichard Braun <rbraun@sceen.net>2018-01-04 21:50:05 +0100
commitb03224b9a82a4d46fd1e469821975f9a5295ed40 (patch)
tree7830e5dc6316f4d29abb3c27c8a7ef77684446df /Makefile.am
parente7321910ca4d956b572a050d302a25df37ce06ab (diff)
Move sources to new src/ directory
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am58
1 files changed, 29 insertions, 29 deletions
diff --git a/Makefile.am b/Makefile.am
index 8586419..709b938 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,7 @@ AM_CPPFLAGS = \
-pipe \
-std=gnu11 \
-imacros config.h \
- -I$(top_srcdir)
+ -I$(top_srcdir)/src
AM_CFLAGS = \
-Wall \
@@ -15,34 +15,34 @@ AM_CFLAGS = \
lib_LTLIBRARIES = librbraun.la
librbraun_la_SOURCES = \
- avltree.c \
- avltree.h \
- avltree_i.h \
- bitmap.c \
- bitmap.h \
- bitmap_i.h \
- cbuf.c \
- cbuf.h \
- check.h \
- cpu.h \
- fmt.c \
- fmt.h \
- hash.h \
- hlist.h \
- list.c \
- list.h \
- macros.h \
- plist.c \
- plist.h \
- rbtree.c \
- rbtree.h \
- rbtree_i.h \
- rdxtree.c \
- rdxtree.h \
- rdxtree_i.h \
- slist.h \
- shell.c \
- shell.h
+ src/avltree.c \
+ src/avltree.h \
+ src/avltree_i.h \
+ src/bitmap.c \
+ src/bitmap.h \
+ src/bitmap_i.h \
+ src/cbuf.c \
+ src/cbuf.h \
+ src/check.h \
+ src/cpu.h \
+ src/fmt.c \
+ src/fmt.h \
+ src/hash.h \
+ src/hlist.h \
+ src/list.c \
+ src/list.h \
+ src/macros.h \
+ src/plist.c \
+ src/plist.h \
+ src/rbtree.c \
+ src/rbtree.h \
+ src/rbtree_i.h \
+ src/rdxtree.c \
+ src/rdxtree.h \
+ src/rdxtree_i.h \
+ src/slist.h \
+ src/shell.c \
+ src/shell.h
librbraun_la_LIBADD = -lrt -lpthread