summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Braun <rbraun@sceen.net>2017-06-17 18:19:44 +0200
committerRichard Braun <rbraun@sceen.net>2017-06-17 18:43:21 +0200
commit50d58f6626a27029dc45e24a309f2b5e6cf75084 (patch)
tree31f8cb696ed063f7148662d30d9214abfeacbb95 /Makefile.am
parent9d2768ff9c5d303a5d548505249b5f411d1e19e2 (diff)
cbuf: implement buffered reads and writes
This change brings an interface for fast buffered accesses to the content of a circular buffer, and also an interface to write into a circular buffer at custom locations, in exchange for a small interface break of cbuf_read.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 96217e2..0835ada 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,6 +50,7 @@ librbraun_la_LIBADD = -lrt -lpthread
bin_PROGRAMS = \
test_avltree \
+ test_cbuf \
test_fmt_sprintf \
test_fmt_sscanf \
test_plist \
@@ -60,6 +61,9 @@ bin_PROGRAMS = \
test_avltree_SOURCES = test/test_avltree.c
test_avltree_LDADD = librbraun.la
+test_cbuf_SOURCES = test/test_cbuf.c
+test_cbuf_LDADD = librbraun.la
+
test_fmt_sprintf_SOURCES = test/test_fmt_sprintf.c
test_fmt_sprintf_LDADD = librbraun.la