summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Braun <rbraun@sceen.net>2013-06-07 20:44:18 +0200
committerRichard Braun <rbraun@sceen.net>2013-06-07 20:44:18 +0200
commit271920aa32395874bb37145d3edb1158217095c9 (patch)
tree475b46ca857ea7903a9d818998871af7400d4bd9 /Makefile.am
parentd7e9a6374fdbd90a0ee592fc4233549bb02dfc8c (diff)
Remove non data-structure code
The primary purpose of this project was testing code in userspace before pushing it to the x15 microkernel. The xprintf and phys modules were included quite some time ago now, along with the mem module which is also present in the GNU Mach microkernel. The secondary goal of this project was to create good implementations of commonly used data structures, mainly the doubly linked list and the red-black tree, under a BSD license so that they're reusable in proprietary projects I have to work on. Such generic code remains in this repository.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am54
1 files changed, 3 insertions, 51 deletions
diff --git a/Makefile.am b/Makefile.am
index 55da9a2..d685fce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,72 +25,24 @@ librbraun_la_SOURCES = \
list.c \
list.h \
macros.h \
- mem.c \
- mem.h \
- mem_malloc.c \
- mem_malloc.h \
- phys.c \
- phys.h \
rbtree.c \
rbtree.h \
rbtree_i.h \
rdxtree.c \
- rdxtree.h \
- xprintf.c \
- xprintf.h
+ rdxtree.h
+
librbraun_la_LIBADD = -lrt -lpthread
bin_PROGRAMS = \
test_avltree \
- test_mem \
- test_mem_cache \
- test_mem_cache_invalid_free \
- test_mem_cache_double_free \
- test_mem_cache_write_free \
- test_mem_cache_write_beyond \
- test_mem_cache_write_buftag \
- test_mem_offbyone \
- test_phys \
test_rbtree \
- test_rdxtree \
- test_xprintf
+ test_rdxtree
test_avltree_SOURCES = test/test_avltree.c
test_avltree_LDADD = librbraun.la
-test_mem_SOURCES = test/test_mem.c
-test_mem_LDADD = librbraun.la
-
-test_mem_cache_SOURCES = test/test_mem_cache.c
-test_mem_cache_LDADD = -lrt -lpthread
-
-test_mem_cache_invalid_free_SOURCES = test/test_mem_cache_invalid_free.c
-test_mem_cache_invalid_free_LDADD = librbraun.la
-
-test_mem_cache_double_free_SOURCES = test/test_mem_cache_double_free.c
-test_mem_cache_double_free_LDADD = librbraun.la
-
-test_mem_cache_write_free_SOURCES = test/test_mem_cache_write_free.c
-test_mem_cache_write_free_LDADD = librbraun.la
-
-test_mem_cache_write_beyond_SOURCES = test/test_mem_cache_write_beyond.c
-test_mem_cache_write_beyond_LDADD = librbraun.la
-
-test_mem_cache_write_buftag_SOURCES = test/test_mem_cache_write_buftag.c
-test_mem_cache_write_buftag_LDADD = librbraun.la
-
-test_mem_offbyone_SOURCES = test/test_mem_offbyone.c
-test_mem_offbyone_LDADD = librbraun.la
-
-test_phys_SOURCES = test/test_phys.c
-test_phys_LDADD = -lrt -lpthread
-
test_rbtree_SOURCES = test/test_rbtree.c
test_rbtree_LDADD = librbraun.la
test_rdxtree_SOURCES = test/test_rdxtree.c
test_rdxtree_LDADD = -lrt -lpthread
-
-test_xprintf_SOURCES = test/test_xprintf.c
-test_xprintf_CFLAGS = $(AM_CFLAGS) -Wno-format
-test_xprintf_LDADD = librbraun.la