summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Braun <rbraun@sceen.net>2017-06-09 20:02:02 +0200
committerRichard Braun <rbraun@sceen.net>2017-06-09 20:02:02 +0200
commit145ee61e2353232b587b5317dee5a67bb5bd7141 (patch)
treec35697938ff7722a3d6aa746900a9eef46f73583 /Makefile.am
parent894c9a466c1449fecd4d9804daeb215c7c5639aa (diff)
fmt: new module
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 225c4e2..96217e2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,6 +27,8 @@ librbraun_la_SOURCES = \
cpu.h \
error.c \
error.h \
+ fmt.c \
+ fmt.h \
hash.h \
list.c \
list.h \
@@ -48,6 +50,8 @@ librbraun_la_LIBADD = -lrt -lpthread
bin_PROGRAMS = \
test_avltree \
+ test_fmt_sprintf \
+ test_fmt_sscanf \
test_plist \
test_rbtree \
test_rdxtree \
@@ -56,6 +60,12 @@ bin_PROGRAMS = \
test_avltree_SOURCES = test/test_avltree.c
test_avltree_LDADD = librbraun.la
+test_fmt_sprintf_SOURCES = test/test_fmt_sprintf.c
+test_fmt_sprintf_LDADD = librbraun.la
+
+test_fmt_sscanf_SOURCES = test/test_fmt_sscanf.c
+test_fmt_sscanf_LDADD = librbraun.la
+
test_plist_SOURCES = test/test_plist.c
test_plist_LDADD = librbraun.la