summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 297e44b..12f66d7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,15 +30,23 @@ else
NEWLIB_SUBDIRS =
endif
+if USE_L4
+ L4_SUBDIRS = libl4 laden
+else
+ L4_SUBDIRS =
+endif
+
if TRAVERSE_HIERARCHY
-SUBDIRS = libl4 libviengoos platform \
+SUBDIRS = libviengoos platform \
$(LIBC_SUBDIRS) $(NEWLIB_SUBDIRS) \
- hurd libhurd-ihash libhurd-btree libbitarray \
+ libhurd-ihash libhurd-btree libbitarray \
+ hurd \
+ libc-parts \
+ $(L4_SUBDIRS) \
libhurd-slab \
libpthread \
libhurd-mm \
- libc-parts \
- laden viengoos \
+ viengoos \
. \
ruth \
benchmarks \