summaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/linux/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/unix/sysv/linux/configure.in')
-rw-r--r--sysdeps/unix/sysv/linux/configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/sysdeps/unix/sysv/linux/configure.in b/sysdeps/unix/sysv/linux/configure.in
index 4ac65d02fa..0c77d7d75f 100644
--- a/sysdeps/unix/sysv/linux/configure.in
+++ b/sysdeps/unix/sysv/linux/configure.in
@@ -40,6 +40,7 @@ fi
if test "$prefix" = "/usr"; then
libc_cv_slibdir="/lib"
libc_cv_sysconfdir="/etc"
+ libc_cv_rootsbindir="/sbin"
fi
# Under Linux the LinuxThreads and crypt add-on should be available.
@@ -79,3 +80,9 @@ if test "$message"; then
echo "$message"
fi
fi
+
+# Check whether `ldconfig' sources are available. This will go away as soon
+# as ldconfig is available in GNU libc.
+if test -f $srcdir/elf/ldconfig.c; then
+ has_ldconfig=yes
+fi