summaryrefslogtreecommitdiff
path: root/sysdeps/mach/hurd/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/mach/hurd/configure.ac')
-rw-r--r--sysdeps/mach/hurd/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/sysdeps/mach/hurd/configure.ac b/sysdeps/mach/hurd/configure.ac
index ad915a568b..db783a0943 100644
--- a/sysdeps/mach/hurd/configure.ac
+++ b/sysdeps/mach/hurd/configure.ac
@@ -17,6 +17,11 @@ case "$machine" in
;;
esac
+if test -n "$sysheaders"; then
+ OLD_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS $SYSINCLUDES"
+fi
+
AC_CACHE_CHECK(Hurd header version, libc_cv_hurd_version, [dnl
AC_TRY_COMPILE(dnl
[#include <hurd/version.h>], [
@@ -29,3 +34,7 @@ AC_TRY_COMPILE(dnl
if test "x$libc_cv_hurd_version" != xok; then
AC_MSG_ERROR(Hurd headers not installed or too old)
fi
+
+if test -n "$sysheaders"; then
+ CPPFLAGS=$OLD_CPPFLAGS
+fi