summaryrefslogtreecommitdiff
path: root/sysdeps/mach/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/mach/configure.ac')
-rw-r--r--sysdeps/mach/configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/sysdeps/mach/configure.ac b/sysdeps/mach/configure.ac
index db85f47eae..cadecae884 100644
--- a/sysdeps/mach/configure.ac
+++ b/sysdeps/mach/configure.ac
@@ -6,6 +6,11 @@ if test "x$MIG" = xMISSING; then
fi
LIBC_CONFIG_VAR([MIG], [$MIG])
+if test -n "$sysheaders"; then
+ OLD_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS $SYSINCLUDES"
+fi
+
### Sanity checks for Mach header installation
AC_CHECK_HEADER(mach/mach_types.h,,
[AC_MSG_ERROR([cannot find Mach headers])], -)
@@ -54,9 +59,9 @@ dnl but we don't do a check for that here because in a bare
dnl environment the compile against those headers will fail.
dnl
mach_interface_list=
-for ifc in mach mach4 \
+for ifc in mach mach4 gnumach \
clock clock_priv host_priv host_security ledger lock_set \
- processor processor_set task thread_act vm_map \
+ processor processor_set task task_notify thread_act vm_map \
memory_object memory_object_default default_pager \
i386/mach_i386 \
; do
@@ -124,3 +129,7 @@ if test $hurd_cv_mig_retcode = yes; then
fi])
hurd_MIG_RETCODE
+
+if test -n "$sysheaders"; then
+ CPPFLAGS=$OLD_CPPFLAGS
+fi