summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e35769afb2..891859c0c0 100644
--- a/configure.in
+++ b/configure.in
@@ -55,7 +55,12 @@ AC_ARG_WITH(weak-symbols, dnl
AC_ARG_ENABLE(libio, dnl
[ --enable-libio build in GNU libio instead of GNU stdio],
- stdio=libio, stdio=default)
+ [if test $enableval = yes; then
+ stdio=libio
+ else
+ stdio=stdio
+ fi],
+ stdio=default)
dnl Arguments to enable or disable building the shared, profiled, and
dnl -fomit-frame-pointer libraries.