summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fb43804b1f..ca795c4486 100644
--- a/configure.in
+++ b/configure.in
@@ -1444,9 +1444,14 @@ EOF
if AC_TRY_COMMAND([${CC-cc} -Wl,--verbose 2>&1|grep DATA_SEGMENT_RELRO_END 1>&AS_MESSAGE_LOG_FD])
then
libc_cv_z_relro=yes
+ else
+ case "$base_machine" in
+ i[34567]86 | x86_64 | powerpc* | s390* | sparc* | alpha*) ;;
+ *) libc_cv_z_relro="not required" ;;
+ esac
fi
fi])
- if test $libc_cv_z_relro != yes; then
+ if test "$libc_cv_z_relro" = no; then
AC_MSG_ERROR(linker with -z relro support required)
fi