summaryrefslogtreecommitdiff
path: root/sysdeps/mach/configure.ac
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2015-08-26 23:48:33 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2015-08-26 23:48:33 +0200
commitc60ca31104c8f9433e3fe51aee238c19e09d9943 (patch)
treec451a279936b4ce82a23c10bfb26ec84c557ef12 /sysdeps/mach/configure.ac
parent58695b88a9deaecbcf7794760cc333177edaa2b4 (diff)
Check sysheaders when looking for Mach and Hurd headers
* sysdeps/mach/configure.ac: Add sysheaders check. * sysdeps/mach/configure: Regenerate. * sysdeps/mach/hurd/configure.ac: Add sysheaders check. * sysdeps/mach/hurd/configure: Regenerate.
Diffstat (limited to 'sysdeps/mach/configure.ac')
-rw-r--r--sysdeps/mach/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/sysdeps/mach/configure.ac b/sysdeps/mach/configure.ac
index db85f47eae..00b660c550 100644
--- a/sysdeps/mach/configure.ac
+++ b/sysdeps/mach/configure.ac
@@ -6,6 +6,11 @@ if test "x$MIG" = xMISSING; then
fi
LIBC_CONFIG_VAR([MIG], [$MIG])
+if test -n "$sysheaders"; then
+ OLD_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS $SYSINCLUDES"
+fi
+
### Sanity checks for Mach header installation
AC_CHECK_HEADER(mach/mach_types.h,,
[AC_MSG_ERROR([cannot find Mach headers])], -)
@@ -124,3 +129,7 @@ if test $hurd_cv_mig_retcode = yes; then
fi])
hurd_MIG_RETCODE
+
+if test -n "$sysheaders"; then
+ CPPFLAGS=$OLD_CPPFLAGS
+fi